summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb')
-rw-r--r--_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
new file mode 100644
index 000000000..6ac2f4f29
--- /dev/null
+++ b/_to_remove/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Low level CAN service"
+DESCRIPTION = "AGL Service application for read and decode CAN messages"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/low-level-can-service"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS = "libafb-helpers libappcontroller"
+
+inherit cmake aglwgt pkgconfig ptest
+
+# For now, just enable J1939 on the qemu platforms where we know the
+# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
+AGLWGT_CMAKE_CONFIGURE_ARGS:append:qemuall = " -DWITH_FEATURE_J1939=ON"
+
+RDEPENDS:${PN} = "virtual/low-can-dev-mapping"