summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/launcher
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-demo/launcher
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-demo/launcher')
-rw-r--r--_to_remove/recipes-demo/launcher/launcher_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/launcher/launcher_git.bb b/_to_remove/recipes-demo/launcher/launcher_git.bb
new file mode 100644
index 000000000..d2de209a1
--- /dev/null
+++ b/_to_remove/recipes-demo/launcher/launcher_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibhomescreen \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
+ agl-compositor \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+RDEPENDS:${PN} = "agl-service-homescreen"