summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/mixer
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-demo/mixer
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-demo/mixer')
-rw-r--r--_to_remove/recipes-demo/mixer/mixer_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/mixer/mixer_git.bb b/_to_remove/recipes-demo/mixer/mixer_git.bb
new file mode 100644
index 000000000..c99c04420
--- /dev/null
+++ b/_to_remove/recipes-demo/mixer/mixer_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Mixer application"
+DESCRIPTION = "AGL demonstration Mixer application for control of PipeWire mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ qtquickcontrols2 \
+ qtwebsockets \
+ libafb-helpers-qt \
+"
+
+PROVIDES += "virtual/mixer"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS:${PN} = "agl-service-audiomixer"
+RPROVIDES:${PN} += "virtual/mixer"