summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb')
-rw-r--r--_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb b/_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb
new file mode 100644
index 000000000..947e0c6a5
--- /dev/null
+++ b/_to_remove/recipes-demo/simple-can-simulator/simple-can-simulator.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Simulator that generates CAN messages of a driving car"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/simple_can_simulator.py;beginline=2;endline=22;md5=9bb9c582301261d21460d2bc5bb8c225"
+
+SRC_URI = "file://simple_can_simulator.py"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/simple_can_simulator.py ${D}${sbindir}
+}
+
+RDEPENDS:${PN} = "python3"