summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch')
-rw-r--r--_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch b/_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch
new file mode 100644
index 000000000..7db57802b
--- /dev/null
+++ b/_to_remove/recipes-kernel/sllin/files/0001_update_makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/sllin/Makefile b/sllin/Makefile
+index 8ae7510..037846f 100644
+--- a/sllin/Makefile
++++ b/sllin/Makefile
+@@ -1,10 +1,11 @@
+ obj-m += sllin.o
+-KPATH=/lib/modules/$(shell uname -r)/build
++KPATH=$(KERNEL_SRC)
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/3.0.4
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/2.6.36
+-
++SRC := $(shell pwd)
+ all:
+- make -C ${KPATH} M=$(PWD) modules
+-
++ make -C ${KPATH} M=$(SRC) modules
++modules_install:
++ make -C ${KPATH} M=$(SRC) modules_install
+ clean:
+- make -C ${KPATH} M=$(PWD) clean
++ make -C ${KPATH} M=$(SRC) clean