summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-support
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:06:49 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 21:47:35 +0200
commit22826f0f164d48ceef18343d9e9c2a6eb3de4230 (patch)
tree14c950e6656b8d6eb08a9b56e758f95c5dde0821 /_to_remove/recipes-support
parente82b00a13a62499fdbca9505daaa69b35bf2f77d (diff)
WIP: rm appfw
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6a90dae780a8eca7d684b5842c3af3ee55ebc509
Diffstat (limited to '_to_remove/recipes-support')
-rw-r--r--_to_remove/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch33
-rw-r--r--_to_remove/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch20
-rw-r--r--_to_remove/recipes-support/lin-config/lin-config_git.bb25
-rw-r--r--_to_remove/recipes-support/opencv/opencv_4.%.bbappend1
-rw-r--r--_to_remove/recipes-support/opencv/opencv_agldemo.inc1
5 files changed, 80 insertions, 0 deletions
diff --git a/_to_remove/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch b/_to_remove/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
new file mode 100644
index 000000000..fe08b7d81
--- /dev/null
+++ b/_to_remove/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
@@ -0,0 +1,33 @@
+From 59acd73ba3bd6cc4151b890d135c6d690a83374d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
+Date: Tue, 1 Oct 2019 15:24:07 +0000
+Subject: [PATCH] Change Makefile to use pkg-config for libxml-2.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+instead of xml2-config.
+
+Upstream-Status: Pending
+
+Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+---
+ lin_config/src/Makefile | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index cf5c515..3fc4df1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,5 @@
+-CC=gcc
+-CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `xml2-config --cflags` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
+-LIBS=`xml2-config --libs` `pkg-config --libs libnl-route-3.0`
++CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `pkg-config --cflags libxml-2.0` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
++LIBS=`pkg-config --libs libxml-2.0` `pkg-config --libs libnl-route-3.0`
+ INCLUDE=../../sllin
+ DEBUG=-ggdb
+
+--
+2.16.4
+
diff --git a/_to_remove/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch b/_to_remove/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
new file mode 100644
index 000000000..26364455a
--- /dev/null
+++ b/_to_remove/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
@@ -0,0 +1,20 @@
+Use LDFLAGS when linking
+
+Use LDFLAGS when linking the output binary to quiet QA warnings due to
+missing link flags.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+--- a/Makefile 2019-11-05 11:08:11.060565285 +0000
++++ b/Makefile 2019-11-05 11:09:38.663570084 +0000
+@@ -6,7 +6,7 @@
+ objects = linc_parse_xml.o pcl_config.o sllin_config.o lin_config.o
+
+ lin_config: $(objects)
+- $(CC) $(objects) $(LIBS) -o lin_config
++ $(CC) $(LDFLAGS) $(objects) $(LIBS) -o lin_config
+
+ %.o : %.c %.h
+ $(CC) $(CFLAGS) $(LIBS) -c $< -o $@
diff --git a/_to_remove/recipes-support/lin-config/lin-config_git.bb b/_to_remove/recipes-support/lin-config/lin-config_git.bb
new file mode 100644
index 000000000..7585156f2
--- /dev/null
+++ b/_to_remove/recipes-support/lin-config/lin-config_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "lin-config tool for the sllin driver module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://lin_config.c;beginline=4;endline=9;md5=196a29df19a30dbc752937bdfc819d7a"
+
+DEPENDS += "libnl libxml2"
+
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
+S = "${WORKDIR}/git/lin_config/src"
+
+SRC_URI:append = " \
+ file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+ file://0002-Change-Makefile-to-use-LDFLAGS.patch \
+ "
+
+inherit pkgconfig
+
+PV = "0.1+git${SRCPV}"
+
+do_configure[noexec] = "1"
+
+do_install:append() {
+ install -d ${D}/${bindir}
+ install -m 755 ${S}/lin_config ${D}/${bindir}
+}
diff --git a/_to_remove/recipes-support/opencv/opencv_4.%.bbappend b/_to_remove/recipes-support/opencv/opencv_4.%.bbappend
new file mode 100644
index 000000000..a1016a6d0
--- /dev/null
+++ b/_to_remove/recipes-support/opencv/opencv_4.%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'opencv_agldemo.inc', '', d)}
diff --git a/_to_remove/recipes-support/opencv/opencv_agldemo.inc b/_to_remove/recipes-support/opencv/opencv_agldemo.inc
new file mode 100644
index 000000000..16640023e
--- /dev/null
+++ b/_to_remove/recipes-support/opencv/opencv_agldemo.inc
@@ -0,0 +1 @@
+PACKAGECONFIG:poky = "jpeg png v4l libv4l gstreamer"