summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-agl-ic-container/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-02-13 19:48:05 -0500
committerScott Murray <scott.murray@konsulko.com>2023-02-13 19:48:05 -0500
commit0907a8b8f37e4374eba4f61a63dc29107bcf11f8 (patch)
tree6a865527bad885a16d9557596eb4172c395fadc6 /dynamic-layers/meta-agl-ic-container/recipes-platform
parentc111707a036678c92df8cf633a9ee74f11cdfb13 (diff)
Add example IC EG container demo image
Changes: - Add a meta-agl-ic-container dynamic layer hierarchy to hold metadata dependent on the agl-ic-container feature. - Add configuration to allow building the agl-demo-platform image as a guest container with agl-ic-container. - Add a agl-lxc-demo-platform image that uses agl-demo-platform as the IVI guest container. NOTE: While this image boots, further integration of IC EG work is required to actually successfully boot the agl-demo-platform guest. Bug-AGL: SPEC-4703 Change-Id: I60a46b6ae3c950c4aa25554639d7828462745bfa Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'dynamic-layers/meta-agl-ic-container/recipes-platform')
-rw-r--r--dynamic-layers/meta-agl-ic-container/recipes-platform/images/agl-lxc-demo-platform.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/meta-agl-ic-container/recipes-platform/images/agl-lxc-demo-platform.bb b/dynamic-layers/meta-agl-ic-container/recipes-platform/images/agl-lxc-demo-platform.bb
new file mode 100644
index 00000000..b8402294
--- /dev/null
+++ b/dynamic-layers/meta-agl-ic-container/recipes-platform/images/agl-lxc-demo-platform.bb
@@ -0,0 +1,31 @@
+SUMMARY = "LXC host demo image"
+LICENSE = "MIT"
+
+require recipes-platform/images/lxc-host-image-minimal.bb
+
+CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \
+ agl-container-ivi:agl-demo-platform \
+ "
+
+IMAGE_INSTALL += " \
+ kernel-modules \
+ alsa-utils \
+ packagegroup-pipewire \
+ pipewire-ic-ipc \
+ wireplumber-config-agl \
+"
+
+# packages required for network bridge settings via lxc-net
+IMAGE_INSTALL += " \
+ lxc-networking \
+ iptables-modules \
+ dnsmasq \
+ systemd-netif-config \
+ kernel-module-xt-addrtype \
+ kernel-module-xt-multiport \
+"
+
+# network manager to use
+VIRTUAL-RUNTIME_net_manager = "systemd"
+
+IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles "