summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-04 14:44:46 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-24 09:14:03 +0000
commit94a19893064724d89893252735883cdb0415835f (patch)
tree4bff24f56fd4b235870307e7834d67576038a9e5 /meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb
parentca836399d23e92f20d7ccc02122ab029e695cc6b (diff)
Move agl-demo-control-panel into own layer and feature during qt6 migration
This creates a temporary sublayer for the demo control panel until meta-agl-demo itself is migrated to qt6. Bug-AGL: SPEC-5195 Change-Id: I07f97385600fb695e182b11c528225d5510185d9 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30067
Diffstat (limited to 'meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb')
-rw-r--r--meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb b/meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb
new file mode 100644
index 000000000..763103d45
--- /dev/null
+++ b/meta-agl-demo-control-panel/recipes-graphics/wayland/weston-agl-driver-conf.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Weston systemd configuration to run as agl-driver user"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland systemd"
+
+SRC_URI = "file://weston-agl-driver.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override drop-in
+ install -d ${D}${systemd_system_unitdir}/weston.service.d
+ install -m 0644 ${WORKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "weston agl-users"