summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:46:02 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit63e0ea358f1902b1dd9968b21b5eea649d04329e (patch)
tree4231493c300f4d9ea2c84b6e290919486bf7e0b6 /meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
parent9eda76e3a9c869030ff4bcf66704207753666a6c (diff)
Move html5 demo into sublayer
The HTML5 demo needs additional fixes. Move it into a sublayer and activate with agl-demo-html5. Bug-AGL: SPEC-5188 Change-Id: I2f1a07dcfbcaf7e09d4d0d3aec1aa8f096336287 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30042 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Scott Murray <scott.murray@konsulko.com> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb')
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
new file mode 100644
index 00000000..0afc8514
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Aquarium Demo"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
+APPINFO_FILE = "appinfo-aquarium.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-aquarium"
+AGL_APP_NAME = "Aquarium"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+