summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-12-17 19:49:16 +0100
commit6a03aab746284f041af307c0f743b08450ff440f (patch)
tree0e439f515be26cbc1e7c9cab9c264a7ff9d68837 /meta-agl-html5-demo/recipes-demo
parentb97d48fb17f8fcd49eb513a331ccf909a35f2014 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-html5-demo/recipes-demo')
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb2
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 8638c7583..dfefd70f5 100644
--- a/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -33,7 +33,7 @@ SYSTEMD_SERVICE:${PN} = "homescreen.service"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+ install -D -m 0644 ${UNPACKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
}
FILES:${PN} = " \
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
index 1a74a46c0..8bc93f53e 100644
--- a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
@@ -15,7 +15,7 @@ WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install ${WORKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
+ install ${UNPACKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
}
FILES:${PN} = " \