summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:46:02 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit63e0ea358f1902b1dd9968b21b5eea649d04329e (patch)
tree4231493c300f4d9ea2c84b6e290919486bf7e0b6 /meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb
parent9eda76e3a9c869030ff4bcf66704207753666a6c (diff)
Move html5 demo into sublayer
The HTML5 demo needs additional fixes. Move it into a sublayer and activate with agl-demo-html5. Bug-AGL: SPEC-5188 Change-Id: I2f1a07dcfbcaf7e09d4d0d3aec1aa8f096336287 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30042 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Scott Murray <scott.murray@konsulko.com> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb')
-rw-r--r--meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb b/meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb
new file mode 100644
index 00000000..9a466bb3
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-wam/depot_tools/depot-tools-wam-native_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = " A collection of tools for dealing with Chromium development"
+DESCRIPTION = "The Chromium depot_tools suite contains many tools to assist/augment the Chromium development environment."
+HOMEPAGE = "https://commondatastorage.googleapis.com/chrome-infra-docs/flat/depot_tools/docs/html/depot_tools_tutorial.html"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c2c05f9bdd5fc0b458037c2d1fb8d95e"
+
+SRC_URI = "git://chromium.googlesource.com/chromium/tools/depot_tools.git;protocol=https;branch=main"
+SRCREV = "64b61755572b1d03b3a43f1a29b617dcae3a3fe0"
+
+S = "${WORKDIR}/git"
+
+inherit native
+
+do_compile[network] = "1"
+do_compile() {
+ export PATH=${S}:$PATH
+ ./ensure_bootstrap
+}
+
+do_install() {
+ install -d ${D}${datadir}/depot_tools
+ cp -aR --no-dereference --no-preserve=owner ${WORKDIR}/git/. ${D}${datadir}/depot_tools
+}
+
+INSANE_SKIP:${PN} += "already-stripped file-rdeps"
+
+BBCLASSEXTEND = "native"
+
+FILES:${PN}-dev += " \
+ ${datadir}/depot_tools/* \
+"