summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-12-19 22:41:31 -0500
commitb8f5c41d1d447795ffa72e3ceeeaf12f6f0e1605 (patch)
tree7db11a20de9ca399678bbd8c12b70cdf394b85e4 /meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
parentd100e89de22d6a950b3caab4d060b7e8dc3f4e15 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-html5-demo/recipes-wam/wam/wam_git.bb')
-rw-r--r--meta-agl-html5-demo/recipes-wam/wam/wam_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb b/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
index f76641e51..9bfb1f98f 100644
--- a/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
+++ b/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
@@ -32,8 +32,8 @@ SYSTEMD_SERVICE:${PN} = "WebAppMgr.service"
do_install:append() {
install -v -d ${D}${sysconfdir}/wam
install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
- install -v -D -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
- install -v -D -m 755 ${WORKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
+ install -v -D -m 644 ${UNPACKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
+ install -v -D -m 755 ${UNPACKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
}
CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"