aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-07-08 13:09:57 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-09 09:32:55 +0000
commit0cbf31a2335287a817fd06eb4410c1c883aacfcb (patch)
tree360eeb487faf6eef327c1cf67146c51c47ce0d19 /meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb
parentcbd12fb404169e9b755b87ac1d1280cbd90a4729 (diff)
meta-agl-kvm-demo: update for YP scarthgap and clean upricefish_18.0.0ricefish/18.0.018.0.0
Note that while these changes do get the KVM demo images building and bootable, some further investigation is required into getting the guest displays rendering to the outputs. Changes: - Move some of the feature template and multiconfig files that were accidentally left in meta-agl-demo to meta-agl-kvm-demo. - Rework how MACHINE is defined for the guest multiconfig to make it a bit more obvious how other machines could be supported. Sadly, experimentaion has shown that trying to do a generic virtio-${TUNE_ARCH} or similar scheme does not work with BitBake's parser, so document that a bit. - Update agl-qemu-runner.sh for change to IMAGE_NAME_SUFFIX default value, and qemu now warning about using "-vga" with the "virt" machine which does not support it. - Add new "agl-virtio-guest" feature to AGL_FEATURES in guest to get virtio kernel configuration. Bug-AGL: SPEC-5201 Change-Id: I194a5c49adf6242cd91d205e19a8eecde698ad7e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30117 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb')
-rw-r--r--meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb
index 33f2b921f..b9ae413e5 100644
--- a/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb
+++ b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo.bb
@@ -30,7 +30,7 @@ IMAGE_INSTALL += " \
#IMAGE_LINGUAS = " "
#NO_RECOMMENDATIONS = "1"
-GUEST_MACHINE ?= "virtio-${TUNE_ARCH}"
+GUEST_MACHINE ?= "${AGL_GUEST_MACHINE}"
GUEST_VM1_IMAGE ?= "agl-ivi-demo-flutter-guest"
GUEST_VM2_IMAGE ?= "agl-cluster-demo-flutter-guest"
@@ -56,7 +56,7 @@ install_guest_images() {
name=${image}
rm -rf ${IMAGE_ROOTFS}/var/lib/machines/${name}
install -m 0755 -d ${IMAGE_ROOTFS}/var/lib/machines/${name}
- src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}.ext4"
+ src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}${IMAGE_NAME_SUFFIX}.ext4"
bbnote "Installing ${src}"
install -m 0600 ${src} ${IMAGE_ROOTFS}/var/lib/machines/${name}/
# Placeholder until booting from kernel in VM image is worked out