summaryrefslogtreecommitdiffstats
path: root/meta-agl-kvm-demo/recipes-platform/images
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-16 18:24:25 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-29 10:27:17 +0000
commit25ec251da61ff53495d609b3400db0a1d7f957d7 (patch)
treee2e62e8a3f9a6b63f31d101387483a536111988c /meta-agl-kvm-demo/recipes-platform/images
parent2f6a12454e558f79f24d4f76bf9c6a16590a5bca (diff)
Add gateway demo
Changes: - Add recipe for AGL VSS to MQTT proxy daemon - Update agl-vcar.dbc CAN database definition to add signals useful for demoing the proxy (per V2C EG discussion). - Add a patch to kuksa-dbc-feeder to allow sensor signal updates to generate CAN messages in output mode. - Add VSS vspec variants to define the desired CAN input and output support for the various kuksa-dbc-feeder instances in the default and full gateway demos. - Add configurations for kuksa-dbc-feeder for the running the default gateway demo with CAN output from a demo control panel instance on a single CAN interface, as well as a fuller setup with a second kuksa-dbc-feeder running against a second CAN interface on the gateway to handle the demo steering wheel and HVAC support. - Add gateway demo specific configuration files for various KUKSA.val databroker clients to override the databroker location. - Add agl-gateway-demo and agl-gateway-demo-preconfigured images for the default and full demos. - Add *-preconfigured-gateway image flavors for the Flutter IVI, IC, and KVM demo images that support running with the databroker on the gateway. NOTES: - The *-preconfigured-gateway images assume the gateway has an IP address of 192.168.10.4. - Required changes to the agl-demo-control-panel application and the addition of a agl-ivi-demo-control-panel-preconfigured-gateway image will come in a subsequent change. Bug-AGL: SPEC-5107, SPEC-5138 Change-Id: I9797aa72737af7af3d791a5151198f80b6d90e0d Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29906 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-kvm-demo/recipes-platform/images')
-rw-r--r--meta-agl-kvm-demo/recipes-platform/images/agl-cluster-demo-flutter-guest-preconfigured-gateway.bb5
-rw-r--r--meta-agl-kvm-demo/recipes-platform/images/agl-ivi-demo-flutter-guest-preconfigured-gateway.bb7
-rw-r--r--meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured-gateway.bb18
-rw-r--r--meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured.bb8
4 files changed, 33 insertions, 5 deletions
diff --git a/meta-agl-kvm-demo/recipes-platform/images/agl-cluster-demo-flutter-guest-preconfigured-gateway.bb b/meta-agl-kvm-demo/recipes-platform/images/agl-cluster-demo-flutter-guest-preconfigured-gateway.bb
new file mode 100644
index 00000000..2377d87d
--- /dev/null
+++ b/meta-agl-kvm-demo/recipes-platform/images/agl-cluster-demo-flutter-guest-preconfigured-gateway.bb
@@ -0,0 +1,5 @@
+require agl-cluster-demo-flutter-guest-preconfigured.bb
+
+SUMMARY = "AGL KVM + gateway demo preconfigured guest cluster Flutter image"
+
+FLUTTER_CLUSTER_DASHBOARD_CONF = "flutter-cluster-dashboard-conf-gateway-demo"
diff --git a/meta-agl-kvm-demo/recipes-platform/images/agl-ivi-demo-flutter-guest-preconfigured-gateway.bb b/meta-agl-kvm-demo/recipes-platform/images/agl-ivi-demo-flutter-guest-preconfigured-gateway.bb
new file mode 100644
index 00000000..2e9b2ccb
--- /dev/null
+++ b/meta-agl-kvm-demo/recipes-platform/images/agl-ivi-demo-flutter-guest-preconfigured-gateway.bb
@@ -0,0 +1,7 @@
+require agl-ivi-demo-flutter-guest-preconfigured.bb
+
+SUMMARY = "AGL KVM + gateway demo preconfigured guest IVI Flutter image"
+
+FLUTTER_ICS_HOMESCREEN_CONF = "flutter-ics-homescreen-conf-kvm-gateway-demo"
+ONDEMANDNAVI_CONF = "ondemandnavi-conf-gateway-demo"
+TBTNAVI_CONF = "tbtnavi-conf-gateway-demo"
diff --git a/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured-gateway.bb b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured-gateway.bb
new file mode 100644
index 00000000..b98f52ee
--- /dev/null
+++ b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured-gateway.bb
@@ -0,0 +1,18 @@
+require agl-kvm-demo-flutter-preconfigured.bb
+
+SUMMARY = "AGL KVM + gateway preconfigured Flutter demo image"
+
+# We only want KUKSA.val client support, not the databroker (since
+# that will be running on the gateway)
+IMAGE_FEATURES:remove = "kuksa-val-databroker"
+
+# Not needed if we're not running the databroker
+IMAGE_INSTALL:remove = "kuksa-databroker-agl-demo-cluster"
+
+IMAGE_INSTALL += "\
+ agl-service-hvac-conf-gateway-demo \
+ agl-service-audiomixer-conf-gateway-demo \
+"
+
+GUEST_VM1_IMAGE = "agl-ivi-demo-flutter-guest-preconfigured-gateway"
+GUEST_VM2_IMAGE = "agl-cluster-demo-flutter-guest-preconfigured-gateway"
diff --git a/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured.bb b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured.bb
index 9b02c68c..ac392cbc 100644
--- a/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured.bb
+++ b/meta-agl-kvm-demo/recipes-platform/images/agl-kvm-demo-flutter-preconfigured.bb
@@ -1,11 +1,9 @@
-LICENSE = "MIT"
-
require agl-kvm-demo.bb
-SUMMARY = "AGL KVM+QEMU preconfigured Flutter demo image"
+SUMMARY = "AGL KVM preconfigured Flutter demo image"
-# If building with "agl-kvm-host-kuksa", the databroker and likely
-# some clients run on the host
+# The databroker runs on the host to simplify things when running
+# clients on the host instead of just in the guests.
IMAGE_FEATURES += " \
kuksa-val-databroker \
kuksa-val-databroker-client \