summaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-08-19 18:37:51 -0400
committerScott Murray <scott.murray@konsulko.com>2020-08-19 18:37:51 -0400
commit5bdba822918cfffb69c0e1983661c32586bed590 (patch)
treeb1fa11566e42190acc9b9cdda912a7cf2ed50ded /recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
parent1677ce2027c49763ec186018f8cbf8fcec64c04f (diff)
Add can-dev-mapping-helperjellyfish_9.99.3jellyfish/9.99.39.99.3
Changes: - Add a can-dev-mapping-helper.sh script and systemd unit to drive it, the script checks if the CAN devices specified in the low-can configuration file /etc/dev-mapping.conf exist, and if not brings up corresponding virtual CAN devices. - Add a systemd over-ride conf file for agl-service-can-low-level that makes can-dev-mapping-helper a dependency. This should ensure that the low-can binding always starts even if there are no physical CAN hardware devices. - Added a Before statement to sllin-demo.service to ensure that it will run before can-dev-mapping-helper and ensure that lin_config can create sllin0 correctly. - Removed the sllin-demo-virtual systemd unit, as it will no longer be required with can-dev-mapping-helper. - Updated the /var/run paths in sllin-demo.service and associated start_lin_demo.sh script to quiet systemd warnings about /var/run usage. Bug-AGL: SPEC-3540 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ife02f75f57ac7bbdee6b02217e2ab657fe8c36e0
Diffstat (limited to 'recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb')
-rw-r--r--recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
new file mode 100644
index 00000000..37793fd6
--- /dev/null
+++ b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Systemd unit for agl-service-can-low-level CAN device helper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://can-dev-mapping-helper.service \
+ file://can-dev-mapping-helper.sh \
+"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS_${PN} += "bash"