summaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-can-low-level
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-apis/agl-service-can-low-level
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-apis/agl-service-can-low-level')
-rw-r--r--recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb4
-rw-r--r--recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend8
-rw-r--r--recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb4
3 files changed, 8 insertions, 8 deletions
diff --git a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
index 83f6c1e7..6ac2f4f2 100644
--- a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
+++ b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -18,6 +18,6 @@ inherit cmake aglwgt pkgconfig ptest
# For now, just enable J1939 on the qemu platforms where we know the
# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
-AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
+AGLWGT_CMAKE_CONFIGURE_ARGS:append:qemuall = " -DWITH_FEATURE_J1939=ON"
-RDEPENDS_${PN} = "virtual/low-can-dev-mapping"
+RDEPENDS:${PN} = "virtual/low-can-dev-mapping"
diff --git a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
index cc198c1c..bc2d0d35 100644
--- a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
+++ b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append = " file://can-dev-mapping-helper.conf"
+SRC_URI:append = " file://can-dev-mapping-helper.conf"
-do_install_append() {
+do_install:append() {
install -D -m 0644 ${WORKDIR}/can-dev-mapping-helper.conf \
${D}${sysconfdir}/systemd/system/afm-service-agl-service-can-low-level-.service.d/can-dev-mapping-helper.conf
}
-RDEPENDS_${PN}_append = " can-dev-mapping-helper"
+RDEPENDS:${PN}:append = " can-dev-mapping-helper"
diff --git a/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
index 37793fd6..cc50bfe2 100644
--- a/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
+++ b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
@@ -16,6 +16,6 @@ do_install() {
install -D -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
}
-FILES_${PN} += "${systemd_system_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"