summaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 17:17:19 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 17:17:19 +0100
commit796f796a2895f2bd840e2eb514532339b53be013 (patch)
tree00c8abe493db22a527d7cf662a478293c958a2bb /recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb
parent41591d4f8c586aa801220fac0924556f406c58bd (diff)
Move core speech service to meta-agl-demokoi_10.91.0koi/10.91.010.91.0
This moves the generic agl-speechframework to meta-agl-demo. The alexa-voiceagent bits remain in meta-agl-devel for now. This fixes a dependency of the settings app. Bug-AGL: SPEC-3734 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: If177271a4a2584ec71ab53ac02764c8065f8b313
Diffstat (limited to 'recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb')
-rw-r--r--recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb b/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb
new file mode 100644
index 00000000..b3c782bb
--- /dev/null
+++ b/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "High level voice service binding"
+DESCRIPTION = "agl-service-voice-high is the binding library"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "json-c systemd af-binder libafb-helpers libappcontroller nlohmann-json glib-2.0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "virtual/voice-high-config"