summaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 17:17:19 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 17:17:19 +0100
commit796f796a2895f2bd840e2eb514532339b53be013 (patch)
tree00c8abe493db22a527d7cf662a478293c958a2bb /recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
parent41591d4f8c586aa801220fac0924556f406c58bd (diff)
Move core speech service to meta-agl-demokoi_10.91.0koi/10.91.010.91.0
This moves the generic agl-speechframework to meta-agl-demo. The alexa-voiceagent bits remain in meta-agl-devel for now. This fixes a dependency of the settings app. Bug-AGL: SPEC-3734 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: If177271a4a2584ec71ab53ac02764c8065f8b313
Diffstat (limited to 'recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb')
-rw-r--r--recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb b/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
new file mode 100644
index 00000000..b015dd5d
--- /dev/null
+++ b/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "High level voice service binding default voiceagent configuration"
+DESCRIPTION = "Default voiceagent JSON configuration file for agl-service-voice-high binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://voice-high.json"
+
+inherit allarch
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/voice-high.json ${D}${sysconfdir}/xdg/AGL/voice-high.json
+}
+
+RPROVIDES_${PN} += "virtual/voice-high-config"
+