summaryrefslogtreecommitdiffstats
path: root/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:46:19 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:48:01 +0100
commitdf9e0ad632b122e19964d2f39588fb5fe2087037 (patch)
treef896d3cefff09a33ff87f0dafe61db7c3c7ab9b3 /recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
parente10617b85d81591de2a5b567d43a1f48cc15aa5f (diff)
parent762181dff011efbaf3d40edb1b3d573c5aceab01 (diff)
Merge branch 'master' of ssh://gerrit.automotivelinux.org:29418/AGL/meta-agl-demo into albacore
Change-Id: Ieedfdda7a1be86c626c6f67b57fed05adb628a87 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb')
-rw-r--r--recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
new file mode 100644
index 000000000..c54e28cc5
--- /dev/null
+++ b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "ambdbusaccess"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad \
+ file://ambdbusaccess.cpp;startline=1;endline=5;md5=0ba6897a99e9332dae1891b4ccf78de3 \
+ "
+
+SRC_URI = "file://* \
+ "
+S = "${WORKDIR}"
+
+DEPENDS = "qtdeclarative qtbase"
+RDEPENDS_${PN} = "automotive-message-broker"
+
+RPROVIDES_${PN} = "ambdbusaccess"
+
+inherit qmake5
+
+do_install () {
+ mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
+ cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+}
+
+FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
+FILES_${PN}-dbg += "${libdir}/qt5/qml/Automotive/.debug"
+