summaryrefslogtreecommitdiffstats
path: root/recipes-automotive/ambdbusaccess
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2016-05-24 06:26:30 +0700
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-29 10:39:42 +0000
commit83c4a67a5daf437f717dd519b3a85f8a803e9357 (patch)
treebe67d6d29b4f3b5dc6e8878bcaa6a3ca58bb2c5b /recipes-automotive/ambdbusaccess
parenta4bb343dcb1e25a99952b3e4da887a2658b05734 (diff)
Refactoring code for installation qml libs
- Use ${libdir} instead of hardcoding /usr/lib - Change to use install command for copy files Change-Id: I4506f69c97ad223b94561fd10b97e5a406c4c4d9 Signed-off-by: Phong Tran <tranmanphong@gmail.com>
Diffstat (limited to 'recipes-automotive/ambdbusaccess')
-rw-r--r--recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
index c54e28cc..e804113d 100644
--- a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
+++ b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
@@ -17,8 +17,8 @@ RPROVIDES_${PN} = "ambdbusaccess"
inherit qmake5
do_install () {
- mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
- cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+ install -d ${D}${libdir}/qt5/qml/Automotive/
+ install -m 0755 ambdbusaccess ${D}${libdir}/qt5/qml/Automotive/
}
FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"