summaryrefslogtreecommitdiffstats
path: root/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-01-06 05:47:48 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 12:55:18 +0000
commit43d99e9b85c4e92f0621c8d26f2443cd98982a41 (patch)
treef0a06083b9c91b4a7f494c686ad512210cc79993 /recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
parentd72179594985169ccc29bfea2dc9c5e6df23e77b (diff)
cluster-demo-support: add recipe for cluster-demo-simulator
The cluster-demo-simulator is a small python script that sends can messages to simulate speed and rpm. It has support for steering wheel events. Bug-AGL: SPEC-3090 . Change-Id: I45bf259c984c59912a674a57ccc642a1917a3209 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> (cherry picked from commit b0620c288705d14aadb9cdd95e47b8b22dc7662a)
Diffstat (limited to 'recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb')
-rw-r--r--recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
new file mode 100644
index 00000000..171ea167
--- /dev/null
+++ b/recipes-config/cluster-demo-simulator/cluster-demo-simulator.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Simulate can messages of a driving car"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "\
+ file://cluster-demo-simulator.service \
+ file://simple_can_simulator.py \
+"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "cluster-demo-simulator.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/cluster-demo-simulator.service ${D}${systemd_system_unitdir}
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/simple_can_simulator.py ${D}${sbindir}
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS_${PN} = " \
+ can-utils \
+ python3 \
+"