summaryrefslogtreecommitdiffstats
path: root/recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-04-26 10:44:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-23 12:13:21 +0000
commit24e22727b7f0c21eeeb62cd536e0c3b25775735b (patch)
treea006b09e21015ba7052202262b868950565506bd /recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb
parentbcc5b2bce4992377120de56cf9886abc10d66f6c (diff)
Rework demo image naming
Rename the demo images to align with the following scheme: agl-<ivi|cluster|etc>-<image|demo>-<qt|flutter|etc>(-<crosssdk|preconfigured>) The intent is to make the naming more consistent in preparation for switching to preconfigured images as a replacement for the existing agl-demo-preload, agl-demo-cluster-support, agl-kvm-host-* aglsetup.sh features. Additionally, the prototype LXC demo image support has been removed as it is unused and would need updating for these and upcoming changes. Bug-AGL: SPEC-5138 Change-Id: I8d907713b09eb47c3cb0ebd5326ab063b2684ea2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29864 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb')
-rw-r--r--recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb b/recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb
deleted file mode 100644
index 8e2aeb3e..00000000
--- a/recipes-config/qemu-config/qemu-config-agl-cluster-demo-platform.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Setting files for agl-cluster-demo-plaform guest VM"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit systemd allarch
-
-SRC_URI = "file://${QEMU_IMAGE}.conf"
-
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-QEMU_IMAGE = "agl-cluster-demo-platform"
-QEMU_UNIT = "agl-qemu-runner@${QEMU_IMAGE}.service"
-
-do_install() {
- # Install template unit links
- install -d ${D}${systemd_system_unitdir}
- ln -sf agl-qemu-runner@.service ${D}${systemd_system_unitdir}/${QEMU_UNIT}
- install -d ${D}${systemd_system_unitdir}/multi-user.target.wants
- ln -sf ${systemd_system_unitdir}/${QEMU_UNIT} ${D}${systemd_system_unitdir}/multi-user.target.wants/${QEMU_UNIT}
-
- # Install conf file
- install -d ${D}${sysconfdir}/agl-qemu-runner
- install -m 0644 ${WORKDIR}/${QEMU_IMAGE}.conf ${D}${sysconfdir}/agl-qemu-runner/
-}
-
-FILES:${PN} += "${systemd_system_unitdir}"
-
-RDEPENDS:${PN} += "agl-qemu-runner qemu-config-vmnet0"