summaryrefslogtreecommitdiffstats
path: root/recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-04-26 10:44:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 20:24:14 +0000
commite3dad1344fee65f54b639f541c7f10352088462b (patch)
treea7606fbf3318d211c5a11fc981a8935a11488233 /recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb
parente62442d3ae45ddb89bc61ced656e682591cc0902 (diff)
Rework demo image naming
Rename the demo images to align with the following scheme: agl-<ivi|cluster|etc>-<image|demo>-<qt|flutter|etc>(-<crosssdk|preconfigured>) The intent is to make the naming more consistent in preparation for switching to preconfigured images as a replacement for the existing agl-demo-preload, agl-demo-cluster-support, agl-kvm-host-* aglsetup.sh features. Additionally, the prototype LXC demo image support has been removed as it is unused and would need updating for these and upcoming changes. Bug-AGL: SPEC-5138 Change-Id: I8d907713b09eb47c3cb0ebd5326ab063b2684ea2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29903 Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb')
-rw-r--r--recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb b/recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb
new file mode 100644
index 000000000..46e043c05
--- /dev/null
+++ b/recipes-config/qemu-config/qemu-config-agl-ivi-demo-qt.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Setting files for agl-demo-plaform guest VM"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://${QEMU_IMAGE}.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+QEMU_IMAGE = "agl-ivi-demo-qt"
+QEMU_UNIT = "agl-qemu-runner@${QEMU_IMAGE}.service"
+
+do_install() {
+ # Install template unit links
+ install -d ${D}${systemd_system_unitdir}
+ ln -sf agl-qemu-runner@.service ${D}${systemd_system_unitdir}/${QEMU_UNIT}
+ install -d ${D}${systemd_system_unitdir}/multi-user.target.wants
+ ln -sf ${systemd_system_unitdir}/${QEMU_UNIT} ${D}${systemd_system_unitdir}/multi-user.target.wants/${QEMU_UNIT}
+
+ # Install conf file
+ install -d ${D}${sysconfdir}/agl-qemu-runner
+ install -m 0644 ${WORKDIR}/${QEMU_IMAGE}.conf ${D}${sysconfdir}/agl-qemu-runner/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "agl-qemu-runner qemu-config-vmnet0"