summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/agl-dbc_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:47:27 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit9eda76e3a9c869030ff4bcf66704207753666a6c (patch)
tree8a77cbed19e883f177f14844c539351b15134b5b /recipes-connectivity/kuksa-val/agl-dbc_git.bb
parent7a356a7e84f6fc7b67a725cfb27d432b782ab43e (diff)
agl-dbc: Add recipe
Add recipe to install the agl-vcar.dbc CAN database file from the newly created agl-dbc repository, remove the copy installed by the kuksa-can-provider-conf-agl recipe, and update various references to it for the new on target path under /usr/share/dbc. Bug-AGL: SPEC-5119 Change-Id: I9a21128c6daa13761e575bad4363be09a3efe808 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30039 ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/agl-dbc_git.bb')
-rw-r--r--recipes-connectivity/kuksa-val/agl-dbc_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/agl-dbc_git.bb b/recipes-connectivity/kuksa-val/agl-dbc_git.bb
new file mode 100644
index 000000000..ee36f9b61
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/agl-dbc_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "CAN database (DBC) files for AGL demos"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f814e94ea4f54c1cdeb3fa60579ca000"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-dbc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "e215d8663370fcdb477d1bc20b434b7e4295fab7"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${datadir}/dbc
+ install -m 0644 ${S}/agl-vcar.dbc ${D}${datadir}/dbc/
+}
+
+FILES:${PN} += "${datadir}/dbc"