summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:11:03 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit7a356a7e84f6fc7b67a725cfb27d432b782ab43e (patch)
tree423cacaa2598cbccdb80e9f85f5496c7818e338d /recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
parent7618c4a08229834883c8ade90e52c8c41eb81901 (diff)
Move base VSS and KUKSA.val recipes to meta-agl-kuksa-val
Remove base VSS and KUKSA.val recipes, as they are moving to a new meta-agl-kuksa-val layer in the meta-agl repository. The recipes for the Python modules they depend on have also been moved. Additional changes: - A new kuksa-can-provider-conf-agl recipe has been added to install our common AGL-specific kuksa-can-provider configuration. The intent is that the kuksa-can-provider in meta-agl-kuksa-val not be dependent on our demo configuration choices. - The other kuksa-can-provider configuration recipes have been tweaked to mark them as allarch. - The python3-argparse-addons recipe and python3-cantools bbappend that used it have been removed, as it looks like it is no longer required. - The dangling kuksa-val-agl-demo-cluster recipe has been removed, it was missed in the previous kuksa-val server removal. Bug-AGL: SPEC-5136 Change-Id: I8c5aa556a796852c5ee3d8c26e045a089911f37e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30038 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
new file mode 100644
index 00000000..64f194d7
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
@@ -0,0 +1,32 @@
+SUMMARY = "KUKSA.val CAN provider configuration for AGL demos"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://config.ini \
+ file://can-provider.token \
+ file://dbc_default_values.json \
+ file://can-dev-helper.conf \
+ file://agl-vcar.dbc \
+"
+
+S = "${WORKDIR}"
+
+inherit allarch systemd
+
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/kuksa-can-provider
+ install -m 0644 ${WORKDIR}/config.ini ${D}${sysconfdir}/kuksa-can-provider/
+ install -m 0644 ${WORKDIR}/can-provider.token ${D}${sysconfdir}/kuksa-can-provider/
+ install -m 0644 ${WORKDIR}/dbc_default_values.json ${D}${sysconfdir}/kuksa-can-provider/
+ install -m 0644 ${WORKDIR}/agl-vcar.dbc ${D}${sysconfdir}/kuksa-can-provider/
+ install -d ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d
+ install -m 0644 ${WORKDIR}/can-dev-helper.conf ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "kuksa-can-provider can-dev-helper"
+RPROVIDES:${PN} += "kuksa-can-provider-conf"