summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:11:03 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit7a356a7e84f6fc7b67a725cfb27d432b782ab43e (patch)
tree423cacaa2598cbccdb80e9f85f5496c7818e338d /recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb
parent7618c4a08229834883c8ade90e52c8c41eb81901 (diff)
Move base VSS and KUKSA.val recipes to meta-agl-kuksa-val
Remove base VSS and KUKSA.val recipes, as they are moving to a new meta-agl-kuksa-val layer in the meta-agl repository. The recipes for the Python modules they depend on have also been moved. Additional changes: - A new kuksa-can-provider-conf-agl recipe has been added to install our common AGL-specific kuksa-can-provider configuration. The intent is that the kuksa-can-provider in meta-agl-kuksa-val not be dependent on our demo configuration choices. - The other kuksa-can-provider configuration recipes have been tweaked to mark them as allarch. - The python3-argparse-addons recipe and python3-cantools bbappend that used it have been removed, as it looks like it is no longer required. - The dangling kuksa-val-agl-demo-cluster recipe has been removed, it was missed in the previous kuksa-val server removal. Bug-AGL: SPEC-5136 Change-Id: I8c5aa556a796852c5ee3d8c26e045a089911f37e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30038 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb b/recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb
deleted file mode 100644
index 16861fcf..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-can-provider_git.bb
+++ /dev/null
@@ -1,66 +0,0 @@
-SUMMARY = "CAN provider for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
-HOMEPAGE = "https://github.com/eclipse-kuksa"
-BUGTRACKER = "https://github.com/eclips-kuksa/kuksa-can-provider/issues"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
-
-DEPENDS = "python3-setuptools-git-versioning-native"
-
-PV = "0.4.3+git${SRCPV}"
-
-SRC_URI = "git://github.com/eclipse-kuksa/kuksa-can-provider.git;protocol=https;branch=main \
- file://0001-dbc2val-add-installation-mechanism.patch \
- file://0002-dbc2val-usability-improvements.patch \
- file://0003-dbc2val-fix-token-file-configuration-option.patch \
- file://0004-Enable-val2dbc-for-sensor-values.patch \
- file://config.ini \
- file://can-provider.token \
- file://agl-vcar.dbc \
- file://dbc_default_values.json \
- file://kuksa-can-provider.service \
- file://kuksa-can-provider.default \
- "
-SRCREV = "d5fdcfa7574ce69059b6f449629571db0982c1cf"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools3 systemd update-alternatives
-
-#SETUPTOOLS_SETUP_PATH = "${S}/dbc2val"
-
-SYSTEMD_SERVICE:${PN} = "${BPN}.service"
-
-do_install:append() {
- install -d ${D}${sysconfdir}/kuksa-can-provider
- install -m 0644 ${WORKDIR}/config.ini ${D}${sysconfdir}/kuksa-can-provider/
- # Token should ideally not be readable by other users.
- # The potential for running the feeder as non-root will take some
- # investigation.
- install -m 0600 ${WORKDIR}/can-provider.token ${D}${sysconfdir}/kuksa-can-provider/
- install -m 0644 ${WORKDIR}/agl-vcar.dbc ${D}${sysconfdir}/kuksa-can-provider/
- install -m 0644 ${WORKDIR}/dbc_default_values.json ${D}${sysconfdir}/kuksa-can-provider/
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/kuksa-can-provider.default ${D}${sysconfdir}/default/
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/kuksa-can-provider.service ${D}${systemd_system_unitdir}
- fi
-}
-
-ALTERNATIVE_LINK_NAME[kuksa-can-provider.env] = "${sysconfdir}/default/kuksa-can-provider"
-
-ALTERNATIVE_TARGET_${PN} = "${sysconfdir}/default/kuksa-can-provider.default"
-FILES:${PN} += "${systemd_system_unitdir}"
-
-RDEPENDS:${PN} += " \
- bash \
- python3-pyserial \
- python3-cantools \
- python3-can \
- python3-can-j1939 \
- python3-pyyaml \
- python3-py-expression-eval \
- kuksa-client \
- can-dev-helper \
-"