summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-08-15 17:35:59 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-09-11 12:50:27 +0000
commit7dcdecf5b01f48a8fbd16fe05ebede08bf5b76a8 (patch)
treed65ebd51edf1da848c87b1e1367c910510b09439 /recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
parent93500637270f0d2e5f4a4185c09e65661e101a82 (diff)
Upgrade KUKSA.val components to 0.4.0 releasespike_16.0.2pike_16.0.1pike/16.0.2pike/16.0.116.0.216.0.1
Move kuksa.val and kuksa.val.feeders repos to a commit that includes the recent 0.4.0 release plus a few post-release fixes, and update our local patches for the new version. A new patch is required for the databroker to disable the upstream addition of a vendored build of protobuf tooling for the host platform, as that does not work in the OE build enviroment, and is effectively not required since known versions of protoc and libprotobuf are already present. The major change coming in is a rework of TLS support, which requires a minor change to the DBC feeder configuration file that has also been included. Bug-AGL: SPEC-4762 Change-Id: I1a43248f15c9946d9d9dc1e8aacf1c3a96ab45a0 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit a620f3a712bab0dd80c8ecaa49e1ebb062fabbb6) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29202 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch b/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
new file mode 100644
index 00000000..a797b7ef
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
@@ -0,0 +1,88 @@
+From 4c21bc033a84949b557a78e5147b7bd1d4f38aff Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Mon, 7 Aug 2023 15:19:34 -0400
+Subject: [PATCH] Remove protobuf-src usage
+
+The vendoring of a protoc and libprotobuf build that was added in
+commit 890703c9 by using protobuf-src is not really workable with
+OpenEmbedded / Yocto Project, and somewhat undesirable for any
+distribution package builds when it comes to transparency and
+reproducibility. Remove it so that building in OE/YP will work.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ Cargo.lock | 19 -------------------
+ kuksa_databroker/databroker-proto/Cargo.toml | 1 -
+ kuksa_databroker/databroker-proto/build.rs | 1 -
+ 3 files changed, 21 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index 54defdf..2795ace 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -170,15 +170,6 @@ version = "1.1.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa"
+
+-[[package]]
+-name = "autotools"
+-version = "0.2.6"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "aef8da1805e028a172334c3b680f93e71126f2327622faef2ec3d893c0a4ad77"
+-dependencies = [
+- "cc",
+-]
+-
+ [[package]]
+ name = "axum"
+ version = "0.6.19"
+@@ -536,7 +527,6 @@ version = "0.4.0"
+ dependencies = [
+ "prost",
+ "prost-types",
+- "protobuf-src",
+ "tonic",
+ "tonic-build",
+ ]
+@@ -2258,15 +2248,6 @@ dependencies = [
+ "prost",
+ ]
+
+-[[package]]
+-name = "protobuf-src"
+-version = "1.1.0+21.5"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
+-dependencies = [
+- "autotools",
+-]
+-
+ [[package]]
+ name = "quote"
+ version = "1.0.32"
+diff --git a/kuksa_databroker/databroker-proto/Cargo.toml b/kuksa_databroker/databroker-proto/Cargo.toml
+index af73696..023c709 100644
+--- a/kuksa_databroker/databroker-proto/Cargo.toml
++++ b/kuksa_databroker/databroker-proto/Cargo.toml
+@@ -25,4 +25,3 @@ prost-types = { workspace = true }
+
+ [build-dependencies]
+ tonic-build = { workspace = true, features = ["transport", "prost"] }
+-protobuf-src = "1.1.0"
+diff --git a/kuksa_databroker/databroker-proto/build.rs b/kuksa_databroker/databroker-proto/build.rs
+index d02a006..d3a70ac 100644
+--- a/kuksa_databroker/databroker-proto/build.rs
++++ b/kuksa_databroker/databroker-proto/build.rs
+@@ -12,7 +12,6 @@
+ ********************************************************************************/
+
+ fn main() -> Result<(), Box<dyn std::error::Error>> {
+- std::env::set_var("PROTOC", protobuf_src::protoc());
+ tonic_build::configure()
+ .compile_well_known_types(false)
+ .protoc_arg("--experimental_allow_proto3_optional")
+--
+2.41.0
+