summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:11:03 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit7a356a7e84f6fc7b67a725cfb27d432b782ab43e (patch)
tree423cacaa2598cbccdb80e9f85f5496c7818e338d /recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
parent7618c4a08229834883c8ade90e52c8c41eb81901 (diff)
Move base VSS and KUKSA.val recipes to meta-agl-kuksa-val
Remove base VSS and KUKSA.val recipes, as they are moving to a new meta-agl-kuksa-val layer in the meta-agl repository. The recipes for the Python modules they depend on have also been moved. Additional changes: - A new kuksa-can-provider-conf-agl recipe has been added to install our common AGL-specific kuksa-can-provider configuration. The intent is that the kuksa-can-provider in meta-agl-kuksa-val not be dependent on our demo configuration choices. - The other kuksa-can-provider configuration recipes have been tweaked to mark them as allarch. - The python3-argparse-addons recipe and python3-cantools bbappend that used it have been removed, as it looks like it is no longer required. - The dangling kuksa-val-agl-demo-cluster recipe has been removed, it was missed in the previous kuksa-val server removal. Bug-AGL: SPEC-5136 Change-Id: I8c5aa556a796852c5ee3d8c26e045a089911f37e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30038 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch133
1 files changed, 0 insertions, 133 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch b/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
deleted file mode 100644
index c6c2381d..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-From 953c80a2acc2bbb882a2dcbbbf0eae7098cbd1fa Mon Sep 17 00:00:00 2001
-From: Scott Murray <scott.murray@konsulko.com>
-Date: Tue, 18 Jun 2024 15:53:46 -0400
-Subject: [PATCH] Remove protobuf-src usage
-
-The vendoring of a protoc and libprotobuf build that was added in
-commit 890703c9 by using protobuf-src is not really workable with
-OpenEmbedded / Yocto Project, and somewhat undesirable for any
-distribution package builds when it comes to transparency and
-reproducibility. Remove it so that building in OE/YP will work.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
- Cargo.lock | 19 -------------------
- databroker-proto/Cargo.toml | 1 -
- databroker-proto/build.rs | 1 -
- lib/Cargo.lock | 19 -------------------
- 4 files changed, 40 deletions(-)
-
-diff --git a/Cargo.lock b/Cargo.lock
-index eb212b0..fdce813 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -162,15 +162,6 @@ version = "1.3.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "0c4b4d0bd25bd0b74681c0ad21497610ce1b7c91b1022cd21c80c6fbdd9476b0"
-
--[[package]]
--name = "autotools"
--version = "0.2.7"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ef941527c41b0fc0dd48511a8154cd5fc7e29200a0ff8b7203c5d777dbc795cf"
--dependencies = [
-- "cc",
--]
--
- [[package]]
- name = "axum"
- version = "0.6.20"
-@@ -650,7 +641,6 @@ version = "0.4.5"
- dependencies = [
- "prost",
- "prost-types",
-- "protobuf-src",
- "tonic",
- "tonic-build",
- ]
-@@ -2322,15 +2312,6 @@ dependencies = [
- "prost",
- ]
-
--[[package]]
--name = "protobuf-src"
--version = "1.1.0+21.5"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
--dependencies = [
-- "autotools",
--]
--
- [[package]]
- name = "quote"
- version = "1.0.36"
-diff --git a/databroker-proto/Cargo.toml b/databroker-proto/Cargo.toml
-index 9d548b2..2f4a7f1 100644
---- a/databroker-proto/Cargo.toml
-+++ b/databroker-proto/Cargo.toml
-@@ -25,4 +25,3 @@ prost-types = { workspace = true }
-
- [build-dependencies]
- tonic-build = { workspace = true, features = ["transport", "prost"] }
--protobuf-src = "1.1.0"
-diff --git a/databroker-proto/build.rs b/databroker-proto/build.rs
-index d02a006..d3a70ac 100644
---- a/databroker-proto/build.rs
-+++ b/databroker-proto/build.rs
-@@ -12,7 +12,6 @@
- ********************************************************************************/
-
- fn main() -> Result<(), Box<dyn std::error::Error>> {
-- std::env::set_var("PROTOC", protobuf_src::protoc());
- tonic_build::configure()
- .compile_well_known_types(false)
- .protoc_arg("--experimental_allow_proto3_optional")
-diff --git a/lib/Cargo.lock b/lib/Cargo.lock
-index 5ba0b78..7dc93f3 100644
---- a/lib/Cargo.lock
-+++ b/lib/Cargo.lock
-@@ -71,15 +71,6 @@ version = "1.3.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "0c4b4d0bd25bd0b74681c0ad21497610ce1b7c91b1022cd21c80c6fbdd9476b0"
-
--[[package]]
--name = "autotools"
--version = "0.2.7"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ef941527c41b0fc0dd48511a8154cd5fc7e29200a0ff8b7203c5d777dbc795cf"
--dependencies = [
-- "cc",
--]
--
- [[package]]
- name = "axum"
- version = "0.6.20"
-@@ -182,7 +173,6 @@ version = "0.4.5"
- dependencies = [
- "prost",
- "prost-types",
-- "protobuf-src",
- "tonic 0.11.0",
- "tonic-build",
- ]
-@@ -663,15 +653,6 @@ dependencies = [
- "prost",
- ]
-
--[[package]]
--name = "protobuf-src"
--version = "1.1.0+21.5"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
--dependencies = [
-- "autotools",
--]
--
- [[package]]
- name = "quote"
- version = "1.0.36"
---
-2.44.0
-