summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-27 15:28:38 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-30 23:32:10 +0000
commit470045b42e4175ed778a24664c910ed57c510c4f (patch)
tree602aae3536980515d0b45691f14e1168ffc46050 /recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
parentcbeacb02ef678b4c3d53429548bb12105b22b7f0 (diff)
Upgrade KUKSA.val components to 0.4.2 release
Upgrade to the KUKSA.val 0.4.2 release that includes the changes required to build the databroker on RISC-V. Notes: - A patch is required to allow building the databroker with Rust 1.68 instead of 1.70, which is currently not available to us on top of Yocto kirkstone. The patch only fixes the versions of the clap command-line parser crate and some of its direct dependencies to what was effectively being used with 0.4.0, so the risk seems minimal at present. When time permits, backporting Rust 1.70 to kirkstone using a mixin layer will be investigated, as that seems better with respect to handling any more KUKSA.val updates during the Quillback lifecycle. - The new optional VISS support has been enabled in the databroker build, but it has not yet been tested on target (a configuration change is required). - The kuksa-client recipe has been updated to build from the new separate kuksa-python-sdk repository. This futureproofs things a bit, as any further 0.4.x releases will only be buildable from the separate repository instead of kuksa.val as before. - The kuksa-dbc-feeder recipe has been left using the 0.4.0 tag commit for now, as no 0.4.2 tag has been made in the feeders repository. As well, some of the post-0.4.0 changes will require rework of the local patches on our side. Bug-AGL: SPEC-4893 Change-Id: I5f92fdea0095a432977c9fa7da05fe5347f7e789 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29490 Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch b/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
new file mode 100644
index 00000000..05e92c7d
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
@@ -0,0 +1,88 @@
+From 37c2a7380c2b1993e62deee4d80e85ad0340ef78 Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Thu, 23 Nov 2023 10:43:38 -0500
+Subject: [PATCH 2/2] Remove protobuf-src usage
+
+The vendoring of a protoc and libprotobuf build that was added in
+commit 890703c9 by using protobuf-src is not really workable with
+OpenEmbedded / Yocto Project, and somewhat undesirable for any
+distribution package builds when it comes to transparency and
+reproducibility. Remove it so that building in OE/YP will work.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ Cargo.lock | 19 -------------------
+ kuksa_databroker/databroker-proto/Cargo.toml | 1 -
+ kuksa_databroker/databroker-proto/build.rs | 1 -
+ 3 files changed, 21 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index bb9ec7f..383e7e6 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -162,15 +162,6 @@ version = "1.1.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa"
+
+-[[package]]
+-name = "autotools"
+-version = "0.2.6"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "aef8da1805e028a172334c3b680f93e71126f2327622faef2ec3d893c0a4ad77"
+-dependencies = [
+- "cc",
+-]
+-
+ [[package]]
+ name = "axum"
+ version = "0.6.20"
+@@ -604,7 +595,6 @@ version = "0.4.1"
+ dependencies = [
+ "prost",
+ "prost-types",
+- "protobuf-src",
+ "tonic",
+ "tonic-build",
+ ]
+@@ -2244,15 +2234,6 @@ dependencies = [
+ "prost",
+ ]
+
+-[[package]]
+-name = "protobuf-src"
+-version = "1.1.0+21.5"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
+-dependencies = [
+- "autotools",
+-]
+-
+ [[package]]
+ name = "quote"
+ version = "1.0.33"
+diff --git a/kuksa_databroker/databroker-proto/Cargo.toml b/kuksa_databroker/databroker-proto/Cargo.toml
+index 5957b7e..9b92162 100644
+--- a/kuksa_databroker/databroker-proto/Cargo.toml
++++ b/kuksa_databroker/databroker-proto/Cargo.toml
+@@ -25,4 +25,3 @@ prost-types = { workspace = true }
+
+ [build-dependencies]
+ tonic-build = { workspace = true, features = ["transport", "prost"] }
+-protobuf-src = "1.1.0"
+diff --git a/kuksa_databroker/databroker-proto/build.rs b/kuksa_databroker/databroker-proto/build.rs
+index d02a006..d3a70ac 100644
+--- a/kuksa_databroker/databroker-proto/build.rs
++++ b/kuksa_databroker/databroker-proto/build.rs
+@@ -12,7 +12,6 @@
+ ********************************************************************************/
+
+ fn main() -> Result<(), Box<dyn std::error::Error>> {
+- std::env::set_var("PROTOC", protobuf_src::protoc());
+ tonic_build::configure()
+ .compile_well_known_types(false)
+ .protoc_arg("--experimental_allow_proto3_optional")
+--
+2.42.0
+