summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-01-30 15:22:36 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-02 12:19:01 +0000
commit9c70c88b650d6186e31fac4912893bf3aa9b308c (patch)
tree417be055c147998cc80d4573feb795bedacb83bd /recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
parent4d8f8b5303e776bd304d5a086049c0c4f80f8942 (diff)
kuksa-databroker: update for building with Rust 1.70
Remove local patch that hacked the databroker into building with Rust 1.68, and update its crates .inc for building with 1.70. Bug-AGL: SPEC-5060 Change-Id: I567a7de6de703a1bc0dce075e1bc037f0b5ecd5e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29639 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch88
1 files changed, 0 insertions, 88 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch b/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
deleted file mode 100644
index 05e92c7d1..000000000
--- a/recipes-connectivity/kuksa-val/kuksa-databroker/0002-Remove-protobuf-src-usage.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 37c2a7380c2b1993e62deee4d80e85ad0340ef78 Mon Sep 17 00:00:00 2001
-From: Scott Murray <scott.murray@konsulko.com>
-Date: Thu, 23 Nov 2023 10:43:38 -0500
-Subject: [PATCH 2/2] Remove protobuf-src usage
-
-The vendoring of a protoc and libprotobuf build that was added in
-commit 890703c9 by using protobuf-src is not really workable with
-OpenEmbedded / Yocto Project, and somewhat undesirable for any
-distribution package builds when it comes to transparency and
-reproducibility. Remove it so that building in OE/YP will work.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
- Cargo.lock | 19 -------------------
- kuksa_databroker/databroker-proto/Cargo.toml | 1 -
- kuksa_databroker/databroker-proto/build.rs | 1 -
- 3 files changed, 21 deletions(-)
-
-diff --git a/Cargo.lock b/Cargo.lock
-index bb9ec7f..383e7e6 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -162,15 +162,6 @@ version = "1.1.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa"
-
--[[package]]
--name = "autotools"
--version = "0.2.6"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "aef8da1805e028a172334c3b680f93e71126f2327622faef2ec3d893c0a4ad77"
--dependencies = [
-- "cc",
--]
--
- [[package]]
- name = "axum"
- version = "0.6.20"
-@@ -604,7 +595,6 @@ version = "0.4.1"
- dependencies = [
- "prost",
- "prost-types",
-- "protobuf-src",
- "tonic",
- "tonic-build",
- ]
-@@ -2244,15 +2234,6 @@ dependencies = [
- "prost",
- ]
-
--[[package]]
--name = "protobuf-src"
--version = "1.1.0+21.5"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
--dependencies = [
-- "autotools",
--]
--
- [[package]]
- name = "quote"
- version = "1.0.33"
-diff --git a/kuksa_databroker/databroker-proto/Cargo.toml b/kuksa_databroker/databroker-proto/Cargo.toml
-index 5957b7e..9b92162 100644
---- a/kuksa_databroker/databroker-proto/Cargo.toml
-+++ b/kuksa_databroker/databroker-proto/Cargo.toml
-@@ -25,4 +25,3 @@ prost-types = { workspace = true }
-
- [build-dependencies]
- tonic-build = { workspace = true, features = ["transport", "prost"] }
--protobuf-src = "1.1.0"
-diff --git a/kuksa_databroker/databroker-proto/build.rs b/kuksa_databroker/databroker-proto/build.rs
-index d02a006..d3a70ac 100644
---- a/kuksa_databroker/databroker-proto/build.rs
-+++ b/kuksa_databroker/databroker-proto/build.rs
-@@ -12,7 +12,6 @@
- ********************************************************************************/
-
- fn main() -> Result<(), Box<dyn std::error::Error>> {
-- std::env::set_var("PROTOC", protobuf_src::protoc());
- tonic_build::configure()
- .compile_well_known_types(false)
- .protoc_arg("--experimental_allow_proto3_optional")
---
-2.42.0
-