summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-databroker_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:11:03 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit7a356a7e84f6fc7b67a725cfb27d432b782ab43e (patch)
tree423cacaa2598cbccdb80e9f85f5496c7818e338d /recipes-connectivity/kuksa-val/kuksa-databroker_git.bb
parent7618c4a08229834883c8ade90e52c8c41eb81901 (diff)
Move base VSS and KUKSA.val recipes to meta-agl-kuksa-val
Remove base VSS and KUKSA.val recipes, as they are moving to a new meta-agl-kuksa-val layer in the meta-agl repository. The recipes for the Python modules they depend on have also been moved. Additional changes: - A new kuksa-can-provider-conf-agl recipe has been added to install our common AGL-specific kuksa-can-provider configuration. The intent is that the kuksa-can-provider in meta-agl-kuksa-val not be dependent on our demo configuration choices. - The other kuksa-can-provider configuration recipes have been tweaked to mark them as allarch. - The python3-argparse-addons recipe and python3-cantools bbappend that used it have been removed, as it looks like it is no longer required. - The dangling kuksa-val-agl-demo-cluster recipe has been removed, it was missed in the previous kuksa-val server removal. Bug-AGL: SPEC-5136 Change-Id: I8c5aa556a796852c5ee3d8c26e045a089911f37e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30038 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-databroker_git.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-databroker_git.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-databroker_git.bb b/recipes-connectivity/kuksa-val/kuksa-databroker_git.bb
deleted file mode 100644
index 376e6a663..000000000
--- a/recipes-connectivity/kuksa-val/kuksa-databroker_git.bb
+++ /dev/null
@@ -1,56 +0,0 @@
-SUMMARY = "KUKSA.val databroker, the KUKSA Vehicle Abstraction Layer"
-#DESCRIPTION = "KUKSA.val provides a COVESA VSS data model describing data in a vehicle."
-HOMEPAGE = "https://github.com/eclipse/kuksa.val"
-BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
-"
-
-DEPENDS = "protobuf-native grpc-native"
-
-PV = "0.4.5+git${SRCPV}"
-
-SRC_URI = "git://github.com/eclipse-kuksa/kuksa-databroker.git;protocol=https;branch=main \
- file://0001-Remove-protobuf-src-usage.patch \
- file://kuksa-databroker.service \
-"
-SRCREV = "8eb7d1a36ccdbec18f742bcecddf8691cb57df46"
-
-require ${BPN}-crates.inc
-
-S = "${WORKDIR}/git"
-
-inherit cargo cargo-update-recipe-crates systemd useradd
-
-# Enable optional VISS support for potential use by e.g. the web apps
-CARGO_BUILD_FLAGS += "--features viss"
-
-SYSTEMD_SERVICE:${PN} = "${BPN}.service"
-
-USERADD_PACKAGES = "${PN}"
-USERADDEXTENSION = "useradd-staticids"
-GROUPADD_PARAM:${PN} = "-g 900 kuksa ;"
-USERADD_PARAM:${PN} = "--system -g 900 -u 900 -o -d / --shell /bin/nologin kuksa ;"
-
-do_install:append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
- fi
-
- # Install gRPC API protobuf files
- install -d ${D}${includedir}
- cp -dr ${S}/proto/* ${D}${includedir}/
-}
-
-PACKAGE_BEFORE_PN += "${PN}-cli"
-
-FILES:${PN} += "${systemd_system_unitdir} ${datadir}"
-
-FILES:${PN}-cli = "${bindir}/databroker-cli"
-
-# The upstream Cargo.toml builds optimized and stripped binaries, for
-# now disable the QA check as opposed to tweaking the configuration.
-INSANE_SKIP:${PN} = "already-stripped"
-INSANE_SKIP:${PN}-cli = "already-stripped"