summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 20:02:33 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-06 20:27:59 -0400
commit59f8e2629f4295e89197a9d475241e87f0b9749b (patch)
tree4c8c80729b4af24fcff8564ecaa08d64c2ca78ef /recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
parent6d869cb805058bb5be8e2eac93853d430076bcdc (diff)
kuksa-dbc-feeder-sllin: add recipe
Add kuksa-dbc-feeder-sllin recipe to install systemd unit and configuration file to run a second copy of the KUKSA.val DBC feeder against the demo setup's sllin0 interface. The systemd unit will bring up the sllin0 interface by a call to the can-dev-helper.sh script if run on hardware that lacks the LIN adapter. Additionally, the DBC feeder mapping configuration has been updated with the mappings for the steering wheel LIN events, and kuksa-dbc-feeder-sllin has been added to the agl-demo-preload packagegroup for the full AGL demo setup. Bug-AGL: SPEC-4405 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I360bdf050f75b6a505b5c1748c6216972d5723c1
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
new file mode 100644
index 000000000..0a86cbbb9
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Demo LIN configuration for DBC feeder for KUKSA.val"
+HOMEPAGE = "https://github.com/eclipse/kuksa.val"
+BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://config-sllin.ini \
+ file://kuksa-dbc-feeder-sllin.service \
+"
+
+inherit allarch systemd
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
+do_install() {
+ # NOTE: Installing into same /etc directory as the main configuration for now,
+ # this may be worth re-evaluating at some point (e.g. splitting the DBC
+ # files, having a dedicated token, etc.).
+ install -d ${D}${sysconfdir}/kuksa-dbc-feeder
+ install -m 0644 ${WORKDIR}/config-sllin.ini ${D}${sysconfdir}/kuksa-dbc-feeder/
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/kuksa-dbc-feeder-sllin.service ${D}${systemd_system_unitdir}
+ fi
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += " \
+ kuksa-dbc-feeder \
+ can-dev-helper \
+ sllin-demo \
+"