summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-10-11 16:00:28 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-18 04:28:35 +0000
commit54ef381ec92148015cbd743a1b30771cca22f80b (patch)
tree143dc14b4e1596123d86f6d9e85335515f05b23d /recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb
parentc74f6beed1454015b010a403cd726562f79ea829 (diff)
kuksa-val: Upgrade to latest
Changes: - Upgrade kuksa-val and kuksa-viss-client to a commit that includes the 0.2.5 release tag and some fixes past it. The patches for each have been updated against the newer version, with backported ones dropped. - The affected recipes have been updated to include some new gRPC tooling dependencies, and a recipe for a new jsonpath-ng dependency has been added. - Rework the kuksa-dbc-feeder recipe for the splitting out of the example feeders from the main kuksa-val repository. - Rework our local kuksa-dbc-feeder patches against the newer version, as upstream has made several improvements. Also drop the duplicate filtering feature patch, as it seems likely we will not need it going forward. - Update the kuksa-dbc-feeder configuration files to work with the new version. Notable is a change in the engine speed signal naming in VSS 3.0, which is the new default for VSS schema. - The kuksa-val and kuksa-val-feeders trees have changed their licensing from EPL-1.0 to Apache-2.0, update the recipes accordingly. Bug-AGL: SPEC-4587 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibc990767219f79af95929e86361e66beda2d0c9e
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb32
1 files changed, 14 insertions, 18 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb
index b7538d77..b5597d00 100644
--- a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb
+++ b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder_git.bb
@@ -2,31 +2,27 @@ SUMMARY = "DBC feeder for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
HOMEPAGE = "https://github.com/eclipse/kuksa.val"
BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
-LICENSE = "EPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=175792518e4ac015ab6696d16c4f607e"
DEPENDS = "python3-setuptools-git-versioning-native"
-require kuksa-val.inc
+PV = "0.1.0+git${SRCPV}"
-SRC_URI += "file://0001-dbc2val-add-installation-mechanism.patch \
- file://0002-dbc2val-usability-improvements.patch \
- file://0003-dbc2val-add-duplicate-filtering-option.patch \
- file://config.ini \
- file://dbc_feeder.json.token \
- file://mapping.yml \
- file://agl-vcar.dbc \
- file://kuksa-dbc-feeder.service \
+SRC_URI = "git://github.com/eclipse/kuksa.val.feeders.git;protocol=https;branch=main \
+ file://0001-dbc2val-add-installation-mechanism.patch \
+ file://0002-dbc2val-usability-improvements.patch \
+ file://config.ini \
+ file://dbc_feeder.json.token \
+ file://mapping.yml \
+ file://agl-vcar.dbc \
+ file://kuksa-dbc-feeder.service \
"
+SRCREV = "a857a1d6981b7d62b80ac03e60988a0bded3e255"
-inherit setuptools3 systemd
-
-SETUPTOOLS_SETUP_PATH = "${S}/kuksa_feeders"
+S = "${WORKDIR}/git"
-# This is a bit of a workaround as the sed in distutils.bbclass
-# will remove the -S already present in the script otherwise,
-# breaking it.
-PEP517_INSTALL_PYTHON = "-S python3 -u"
+inherit setuptools3 systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"