aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-10-11 16:00:28 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-18 04:28:35 +0000
commit54ef381ec92148015cbd743a1b30771cca22f80b (patch)
tree143dc14b4e1596123d86f6d9e85335515f05b23d /recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb
parentc74f6beed1454015b010a403cd726562f79ea829 (diff)
kuksa-val: Upgrade to latest
Changes: - Upgrade kuksa-val and kuksa-viss-client to a commit that includes the 0.2.5 release tag and some fixes past it. The patches for each have been updated against the newer version, with backported ones dropped. - The affected recipes have been updated to include some new gRPC tooling dependencies, and a recipe for a new jsonpath-ng dependency has been added. - Rework the kuksa-dbc-feeder recipe for the splitting out of the example feeders from the main kuksa-val repository. - Rework our local kuksa-dbc-feeder patches against the newer version, as upstream has made several improvements. Also drop the duplicate filtering feature patch, as it seems likely we will not need it going forward. - Update the kuksa-dbc-feeder configuration files to work with the new version. Notable is a change in the engine speed signal naming in VSS 3.0, which is the new default for VSS schema. - The kuksa-val and kuksa-val-feeders trees have changed their licensing from EPL-1.0 to Apache-2.0, update the recipes accordingly. Bug-AGL: SPEC-4587 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibc990767219f79af95929e86361e66beda2d0c9e
Diffstat (limited to 'recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb')
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb21
1 files changed, 14 insertions, 7 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb b/recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb
index 67f4af25..2a4026bd 100644
--- a/recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb
+++ b/recipes-connectivity/kuksa-val/kuksa-viss-client_git.bb
@@ -2,18 +2,22 @@ SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
HOMEPAGE = "https://github.com/eclipse/kuksa.val"
BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
-LICENSE = "EPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9"
-DEPENDS = "python3-setuptools-git-versioning-native"
+DEPENDS = " \
+ python3-setuptools-git-versioning-native \
+ python3-grpcio-tools-native \
+ python3-grpcio \
+"
require kuksa-val.inc
-SRC_URI += "file://0001-Update-kuksa-viss-client-to-support-Python-3.10.patch \
- file://0002-kuksa_viss_client-Update-cmd2-completer-usage.patch \
-"
+SRC_URI += "file://0001-kuksa_viss_client-Update-cmd2-completer-usage.patch;striplevel=2"
+
+S = "${WORKDIR}/git/kuksa_viss_client"
-inherit setuptools3
+inherit python_setuptools_build_meta
RDEPENDS:${PN} += " \
python3-cmd2 \
@@ -21,6 +25,9 @@ RDEPENDS:${PN} += " \
python3-pkg-resources \
python3-pygments \
python3-websockets \
+ python3-grpcio \
+ python3-grpcio-tools \
+ python3-jsonpath-ng \
"
# A script for generating new certificates currently gets shipped inside