summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/neard
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-connectivity/neard
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-connectivity/neard')
-rw-r--r--recipes-connectivity/neard/files/0001-systemd-neard-add-multi-user.target-to-neard.service.patch25
-rw-r--r--recipes-connectivity/neard/files/0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch33
-rw-r--r--recipes-connectivity/neard/neard_0.16.bbappend1
-rw-r--r--recipes-connectivity/neard/neard_agldemo.inc7
4 files changed, 0 insertions, 66 deletions
diff --git a/recipes-connectivity/neard/files/0001-systemd-neard-add-multi-user.target-to-neard.service.patch b/recipes-connectivity/neard/files/0001-systemd-neard-add-multi-user.target-to-neard.service.patch
deleted file mode 100644
index c3295169..00000000
--- a/recipes-connectivity/neard/files/0001-systemd-neard-add-multi-user.target-to-neard.service.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d8c03a31e2734e59af43dd50cbd7f5a94d798ab1 Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Tue, 10 Jul 2018 21:18:26 -0700
-Subject: [PATCH] systemd: neard: add multi-user.target to neard.service
-
-Allowing a service to be system level requires a WantedBy= target
-
-Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
----
- src/neard.service.in | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/neard.service.in b/src/neard.service.in
-index dfa238c..540da7e 100644
---- a/src/neard.service.in
-+++ b/src/neard.service.in
-@@ -9,4 +9,5 @@ ExecStart=@pkglibexecdir@/neard -n
- LimitNPROC=1
-
- [Install]
-+WantedBy=multi-user.target
- Alias=dbus-org.neard.service
---
-2.17.1
-
diff --git a/recipes-connectivity/neard/files/0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch b/recipes-connectivity/neard/files/0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch
deleted file mode 100644
index 49c11a50..00000000
--- a/recipes-connectivity/neard/files/0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d7ea2a00e00795ad24897e3481b015a27d37d60f Mon Sep 17 00:00:00 2001
-From: Raquel Medina <raquel.medina@konsulko.com>
-Date: Tue, 22 Jan 2019 09:00:05 -0500
-Subject: [PATCH] ndef: avoid dbus property_get_type method on empty record
-
-Signed-off-by: Raquel Medina <raquel.medina@konsulko.com>
----
- src/ndef.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/ndef.c b/src/ndef.c
-index 5656baf..883c6f4 100644
---- a/src/ndef.c
-+++ b/src/ndef.c
-@@ -2832,10 +2832,14 @@ GList *near_ndef_parse_msg(uint8_t *ndef_data, size_t ndef_length,
- case RECORD_TYPE_WKT_ALTERNATIVE_CARRIER:
- case RECORD_TYPE_WKT_COLLISION_RESOLUTION:
- case RECORD_TYPE_WKT_ERROR:
-- case RECORD_TYPE_UNKNOWN:
- case RECORD_TYPE_ERROR:
- break;
-
-+ case RECORD_TYPE_UNKNOWN:
-+ if (record->header->tnf == RECORD_TNF_EMPTY)
-+ goto fail;
-+ break;
-+
- case RECORD_TYPE_WKT_HANDOVER_REQUEST:
- case RECORD_TYPE_WKT_HANDOVER_SELECT:
- /*
---
-2.17.1
-
diff --git a/recipes-connectivity/neard/neard_0.16.bbappend b/recipes-connectivity/neard/neard_0.16.bbappend
deleted file mode 100644
index 2ab0381c..00000000
--- a/recipes-connectivity/neard/neard_0.16.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'neard_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/neard/neard_agldemo.inc b/recipes-connectivity/neard/neard_agldemo.inc
deleted file mode 100644
index 513486fc..00000000
--- a/recipes-connectivity/neard/neard_agldemo.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI:append = "\
- file://0001-systemd-neard-add-multi-user.target-to-neard.service.patch \
- file://0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch \
- "
-SYSTEMD_SERVICE:${PN}:append = " neard.service"