summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/vss/vss-agl_4.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-16 23:54:38 +0900
committerScott Murray <scott.murray@konsulko.com>2023-11-16 21:02:00 +0000
commit39bdfed9e62d301fc139f04b608136345a5ff596 (patch)
tree454cf76c03495d09294832da8e10d0c7a7277786 /recipes-connectivity/vss/vss-agl_4.0.bb
parent4a1b172ebda54d587db7ecfc61af5443d0c11d0d (diff)
Update to VSS 4.0
Update VSS tools and spec recipes from version 3.1.1 to 4.0. Bug-AGL: SPEC-4970 Change-Id: I26a4a1ac3e149013b0ee71426beaba0c7d4731e4 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29416 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/vss/vss-agl_4.0.bb')
-rw-r--r--recipes-connectivity/vss/vss-agl_4.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-connectivity/vss/vss-agl_4.0.bb b/recipes-connectivity/vss/vss-agl_4.0.bb
new file mode 100644
index 00000000..83fb4b1a
--- /dev/null
+++ b/recipes-connectivity/vss/vss-agl_4.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Vehicle Signal Specification with AGL overlays"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+DEPENDS = "vss-tools-native"
+
+inherit allarch update-alternatives
+
+require vss.inc
+
+SRC_URI += "file://agl_vss_overlay.vspec"
+
+# Since we're not relying on the simple upstream repo Makefile, use
+# best practices and output into a separate directory.
+B = "${WORKDIR}/build"
+
+do_configure[noexec] = "1"
+
+VSPEC2JSON_OPTS = "-e dbc -o ${WORKDIR}/agl_vss_overlay.vspec --no-uuid --json-pretty"
+
+do_compile() {
+ vspec2json.py -I ${S}/spec ${VSPEC2JSON_OPTS} -u ${S}/spec/units.yaml ${S}/spec/VehicleSignalSpecification.vspec vss_rel_${PV}-agl.json
+}
+
+do_install() {
+ install -d ${D}${datadir}/vss
+ install -m 0644 vss_rel_${PV}-agl.json ${D}${datadir}/vss/
+}
+
+ALTERNATIVE_LINK_NAME[vss.json] = "${datadir}/vss/vss.json"
+
+ALTERNATIVE_PRIORITY = "20"
+ALTERNATIVE:${PN} = "vss.json"
+ALTERNATIVE_TARGET_${PN} = "${datadir}/vss/vss_rel_${PV}-agl.json"
+
+FILES:${PN} += "${datadir}/vss/"