summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/vss/vss-tools_4.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-16 23:54:38 +0900
committerScott Murray <scott.murray@konsulko.com>2023-11-16 21:02:00 +0000
commit39bdfed9e62d301fc139f04b608136345a5ff596 (patch)
tree454cf76c03495d09294832da8e10d0c7a7277786 /recipes-connectivity/vss/vss-tools_4.0.bb
parent4a1b172ebda54d587db7ecfc61af5443d0c11d0d (diff)
Update to VSS 4.0
Update VSS tools and spec recipes from version 3.1.1 to 4.0. Bug-AGL: SPEC-4970 Change-Id: I26a4a1ac3e149013b0ee71426beaba0c7d4731e4 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29416 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/vss/vss-tools_4.0.bb')
-rw-r--r--recipes-connectivity/vss/vss-tools_4.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-connectivity/vss/vss-tools_4.0.bb b/recipes-connectivity/vss/vss-tools_4.0.bb
new file mode 100644
index 00000000..432dd39b
--- /dev/null
+++ b/recipes-connectivity/vss/vss-tools_4.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "COVESA Vehicle Signal Specification tooling."
+HOMEPAGE = "https://github.com/COVESA/vss-tools"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=master"
+SRCREV = "784505f3005c2350d7861c3add030348e2d910e3"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-email \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-pkg-resources \
+ python3-anytree \
+ python3-deprecation \
+ python3-graphql-core \
+ python3-pyyaml \
+ python3-six \
+"
+
+BBCLASSEXTEND += "native nativesdk"