summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/vss/vss_4.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-18 16:44:10 -0400
committerScott Murray <scott.murray@konsulko.com>2024-06-20 02:04:33 +0000
commite14d6f4b1b25af2fce6af1245b1b6dbc650d3931 (patch)
tree67b8faeed9ce4e465e8054e566e28edca6f0c0b8 /recipes-connectivity/vss/vss_4.0.bb
parent9bdeb3f8da3e4776256b50c5850c17b438377e98 (diff)
vss: Upgrade to 0.4.2
Upgrade recipes for stock VSS schema and AGL's tweaked copy for demos to 0.4.2 release. Bug-AGL: SPEC-5180 Change-Id: I0f90742c3220ab460932ebf8afb19d0498e43a51 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30004 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-connectivity/vss/vss_4.0.bb')
-rw-r--r--recipes-connectivity/vss/vss_4.0.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-connectivity/vss/vss_4.0.bb b/recipes-connectivity/vss/vss_4.0.bb
deleted file mode 100644
index 053516629..000000000
--- a/recipes-connectivity/vss/vss_4.0.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "Vehicle Signal Specification"
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
-
-DEPENDS = "vss-tools-native"
-
-inherit allarch update-alternatives
-
-require vss.inc
-
-UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
-
-S = "${WORKDIR}/git"
-
-do_configure[noexec] = "1"
-
-EXTRA_OEMAKE = "TOOLSDIR=${STAGING_BINDIR_NATIVE}"
-
-do_compile() {
- oe_runmake json
-}
-
-do_install() {
- # Cannot use the "install" target in the project Makefile, as it is
- # intended for setting the repo up for builds.
- # For now, just the generated JSON is installed. It is possible that
- # installing the vspec files somewhere as a development package may
- # be useful, but for now things will be kept simple.
- install -d ${D}${datadir}/vss
- install -m 0644 ${S}/vss_rel_${PV}.json ${D}${datadir}/vss/
-}
-
-# NOTE:
-# A virtual RPROVIDES is not used for now, as packages such as KUKSA.val
-# provide their own copies of the VSS JSON, so we can install this one
-# and any alternatives in parallel and point e.g. KUKSA.val at the desired
-# file with a configuration change. This may be worth revisiting down the
-# road.
-
-ALTERNATIVE_LINK_NAME[vss.json] = "${datadir}/vss/vss.json"
-
-ALTERNATIVE:${PN} = "vss.json"
-ALTERNATIVE_TARGET_${PN} = "${datadir}/vss/vss_rel_${PV}.json"