summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-12 15:09:57 -0400
committerScott Murray <scott.murray@konsulko.com>2023-05-15 18:44:12 +0000
commit6533623201bf90c56a4a611519fab8923e127b2a (patch)
treebe5ebf12a94bd0611aa1e8fdcdbdb2e26aa2328b /recipes-connectivity
parenteb5c52e3d293d358e114312b35ad9d1a9d4b8ae9 (diff)
Add vss-tools and required dependencies
Add a vss-tools recipe to build the VSS specification tools, and recipes for the python3-anytree, python3-deprecation, and python3-graphql-core modules it requires. The latter will be submitted for meta-python. Bug-AGL: SPEC-4761 Change-Id: Iffe665c0c6f168f3c37b35ce0346cad210d880c5 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/vss/vss-tools_3.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-connectivity/vss/vss-tools_3.1.bb b/recipes-connectivity/vss/vss-tools_3.1.bb
new file mode 100644
index 00000000..b681d8dc
--- /dev/null
+++ b/recipes-connectivity/vss/vss-tools_3.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "COVESA Vehicle Signal Specification tooling."
+HOMEPAGE = "https://github.com/COVESA/vss-tools"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=master"
+SRCREV = "97148190d0f84bedfc933b8bc4391c0a7e7a099b"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-email \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-pkg-resources \
+ python3-anytree \
+ python3-deprecation \
+ python3-graphql-core \
+ python3-pyyaml \
+ python3-six \
+"
+
+BBCLASSEXTEND += "native nativesdk"