summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:20:22 -0500
commit12ad591d3038db609db5290d8bbe809a34c743de (patch)
treedbbcc9a44134a012f531d48132c8803c3940bfa2 /recipes-connectivity
parent88c424f8b8c78dfc5520ea9be1866027df4735b8 (diff)
This is effectively a manual cherry-pick and squash of commits: 4249268041b879b3d2bae338d5de88f4f2d54b26 07f4ab8c2833ae5377b97cc9e3820bed67e539d0 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3b47f1b7d62038b314a17763d24a64f6d4e15e72
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/bluez-alsa/bluez-alsa_git.bb8
-rw-r--r--recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend8
-rw-r--r--recipes-connectivity/bluez5/bluez5_agldemo.inc8
-rw-r--r--recipes-connectivity/cluster-connman-conf/cluster-connman-conf_1.0.bb2
-rw-r--r--recipes-connectivity/connman/connman_agldemo.inc2
-rw-r--r--recipes-connectivity/mobile-broadband-provider-info/mobile-broadband-provider-info_agldemo.inc2
-rw-r--r--recipes-connectivity/neard/neard_agldemo.inc6
-rw-r--r--recipes-connectivity/neardal/neardal.inc6
-rw-r--r--recipes-connectivity/ofono/ofono_agldemo.inc6
-rw-r--r--recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb4
10 files changed, 26 insertions, 26 deletions
diff --git a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
index 010329ee..27f462a8 100644
--- a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
+++ b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
@@ -22,21 +22,21 @@ inherit autotools pkgconfig
inherit systemd
SYSTEMD_AUTO_ENABLE = "enable"
-SYSTEMD_SERVICE_${PN} = "bluez-alsa.service"
+SYSTEMD_SERVICE:${PN} = "bluez-alsa.service"
PACKAGECONFIG += "ofono"
# enable debug tools in devel images
PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
PACKAGECONFIG[rfcomm] = "--enable-rfcomm, --disable-rfcomm,"
-PACKAGECONFIG_append_agl-devel = " hcitop rfcomm"
+PACKAGECONFIG:append:agl-devel = " hcitop rfcomm"
-do_install_append () {
+do_install:append () {
install -d ${D}${base_libdir}/systemd/system
install -m 0644 ${WORKDIR}/bluez-alsa.service ${D}${base_libdir}/systemd/system
}
-FILES_${PN} += "\
+FILES:${PN} += "\
${datadir}/alsa/alsa.conf.d/20-bluealsa.conf\
${libdir}/alsa-lib/libasound_module_ctl_bluealsa.so\
${libdir}/alsa-lib/libasound_module_pcm_bluealsa.so\
diff --git a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
index bcb47888..b592e822 100644
--- a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
+++ b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/bluez-alsa:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/bluez-alsa:"
SRC_URI += "\
file://0001-utils-add-a-gstreamer-helper-application-for-interco.patch \
@@ -8,7 +8,7 @@ SRC_URI += "\
PACKAGECONFIG += "gsthelper"
PACKAGECONFIG[gsthelper] = "--enable-gsthelper, --disable-gsthelper, gstreamer1.0"
-do_install_append() {
+do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
# install the service file
mkdir -p ${D}${systemd_system_unitdir}/
@@ -22,12 +22,12 @@ do_install_append() {
PACKAGES =+ "${PN}-pipewire"
-FILES_${PN}-pipewire = "\
+FILES:${PN}-pipewire = "\
${bindir}/bluealsa-gst-helper \
${systemd_system_unitdir}/bluealsa-gst-helper@.service \
${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service \
"
-RDEPENDS_${PN}-pipewire += "\
+RDEPENDS:${PN}-pipewire += "\
bluez-alsa \
pipewire \
gstreamer1.0-plugins-base \
diff --git a/recipes-connectivity/bluez5/bluez5_agldemo.inc b/recipes-connectivity/bluez5/bluez5_agldemo.inc
index 0e9cd62c..588e6302 100644
--- a/recipes-connectivity/bluez5/bluez5_agldemo.inc
+++ b/recipes-connectivity/bluez5/bluez5_agldemo.inc
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/bluez5:"
-SRC_URI_append = " \
+FILESEXTRAPATHS:prepend := "${THISDIR}/bluez5:"
+SRC_URI:append = " \
file://bluetooth.conf \
file://tmpdir.conf \
file://obex.service \
file://bluetooth.service \
"
-FILES_${PN}_append = " ${systemd_user_unitdir}/obex.service.d/tmpdir.conf"
+FILES:${PN}:append = " ${systemd_user_unitdir}/obex.service.d/tmpdir.conf"
-do_install_append() {
+do_install:append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
diff --git a/recipes-connectivity/cluster-connman-conf/cluster-connman-conf_1.0.bb b/recipes-connectivity/cluster-connman-conf/cluster-connman-conf_1.0.bb
index 78528aa7..a6610b75 100644
--- a/recipes-connectivity/cluster-connman-conf/cluster-connman-conf_1.0.bb
+++ b/recipes-connectivity/cluster-connman-conf/cluster-connman-conf_1.0.bb
@@ -12,4 +12,4 @@ do_install() {
${WORKDIR}/cluster.config > ${D}${localstatedir}/lib/connman/cluster.config
}
-FILES_${PN} += "${localstatedir}/*"
+FILES:${PN} += "${localstatedir}/*"
diff --git a/recipes-connectivity/connman/connman_agldemo.inc b/recipes-connectivity/connman/connman_agldemo.inc
index 1900cc14..5b732ae5 100644
--- a/recipes-connectivity/connman/connman_agldemo.inc
+++ b/recipes-connectivity/connman/connman_agldemo.inc
@@ -1,4 +1,4 @@
-do_install_append() {
+do_install:append() {
# Need to ignore eth1 in cluster demo setup
if ${@bb.utils.contains('AGL_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
sed -i 's/^\(NetworkInterfaceBlacklist=.*\)/\1,eth1/' ${D}${sysconfdir}/connman/main.conf
diff --git a/recipes-connectivity/mobile-broadband-provider-info/mobile-broadband-provider-info_agldemo.inc b/recipes-connectivity/mobile-broadband-provider-info/mobile-broadband-provider-info_agldemo.inc
index f64bcfbc..2edd59e2 100644
--- a/recipes-connectivity/mobile-broadband-provider-info/mobile-broadband-provider-info_agldemo.inc
+++ b/recipes-connectivity/mobile-broadband-provider-info/mobile-broadband-provider-info_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/mobile-broadband-provider-info:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/mobile-broadband-provider-info:"
SRC_URI += "file://0001-remove-Fido-service-provider.patch"
diff --git a/recipes-connectivity/neard/neard_agldemo.inc b/recipes-connectivity/neard/neard_agldemo.inc
index f39fc9bc..513486fc 100644
--- a/recipes-connectivity/neard/neard_agldemo.inc
+++ b/recipes-connectivity/neard/neard_agldemo.inc
@@ -1,7 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append = "\
+SRC_URI:append = "\
file://0001-systemd-neard-add-multi-user.target-to-neard.service.patch \
file://0002-ndef-avoid-dbus-property_get_type-method-on-empty-re.patch \
"
-SYSTEMD_SERVICE_${PN}_append = " neard.service"
+SYSTEMD_SERVICE:${PN}:append = " neard.service"
diff --git a/recipes-connectivity/neardal/neardal.inc b/recipes-connectivity/neardal/neardal.inc
index 3bb6b24e..1cad75fb 100644
--- a/recipes-connectivity/neardal/neardal.inc
+++ b/recipes-connectivity/neardal/neardal.inc
@@ -16,7 +16,7 @@ inherit autotools pkgconfig
PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
-FILES_${PN}-tools = "${libexecdir}/ncl"
-FILES_${PN}-tools-dbg += "${libexecdir}/.debug"
+FILES:${PN}-tools = "${libexecdir}/ncl"
+FILES:${PN}-tools-dbg += "${libexecdir}/.debug"
-RDEPENDS_${PN}-tools = "bash"
+RDEPENDS:${PN}-tools = "bash"
diff --git a/recipes-connectivity/ofono/ofono_agldemo.inc b/recipes-connectivity/ofono/ofono_agldemo.inc
index b02d6ee2..26198353 100644
--- a/recipes-connectivity/ofono/ofono_agldemo.inc
+++ b/recipes-connectivity/ofono/ofono_agldemo.inc
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append = "\
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+SRC_URI:append = "\
file://ofono.conf \
file://0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch \
"
-do_install_append() {
+do_install:append() {
install -m 0644 ${WORKDIR}/ofono.conf ${D}${sysconfdir}/dbus-1/system.d/ofono.conf
}
diff --git a/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb b/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb
index 080b5ec4..396beff5 100644
--- a/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb
+++ b/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb
@@ -18,14 +18,14 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--enable-driver-detach"
-do_configure_append() {
+do_configure:append() {
# remove included temporary path from pc file due to pass-through of OE CFLAGS
# debug-prefix-map
# See: http://lists.openembedded.org/pipermail/openembedded-devel/2016-May/107456.html
sed -i -e "s# -fdebug-prefix-map=.*##g;s# -fmacro-prefix-map=.*##g" librtlsdr.pc
}
-do_install_append() {
+do_install:append() {
install -D -m 0644 ${S}/rtl-sdr.rules ${D}${sysconfdir}/udev/rules.d/55-rtl-sdr.rules
sed -i 's/MODE:="0666"/GROUP="audio", MODE="0660", SECLABEL{smack}="*"/' \
${D}${sysconfdir}/udev/rules.d/55-rtl-sdr.rules