summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-12-18 06:10:11 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-19 18:56:27 +0000
commitd403670078f50e006a3870f2a425c5c77364b8f1 (patch)
tree9a467a5ab8fa689ed4baedf30827234f993f8003 /recipes-connectivity
parentc8beec87614a00ae93305c7b4642c1f4f760e051 (diff)
Add libnfc recipes.
libnfc is mandatory for agl service nfc. Change-Id: Ie542178c71a1b34b6925b3c2322a1386b7866fa1 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/libnfc/libnfc_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-connectivity/libnfc/libnfc_git.bb b/recipes-connectivity/libnfc/libnfc_git.bb
new file mode 100644
index 00000000..bd216f81
--- /dev/null
+++ b/recipes-connectivity/libnfc/libnfc_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libnfc"
+DESCRIPTION = "Platform independent Near Field Communication (NFC) library"
+HOMEPAGE = "https://github.com/nfc-tools/libnfc"
+SECTION = "apps"
+
+DEPENDS = "libusb"
+
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
+
+inherit cmake pkgconfig
+
+SRC_URI = "git://github.com/nfc-tools/libnfc;protocol=https;branch=master"
+SRCREV = "2d4543673e9b76c02679ca8b89259659f1afd932"
+
+PV = "1.7.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+