summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-24 15:15:42 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-28 00:29:25 +0200
commitb1ee9d6cb0f28ba3dc5b35be97cd9507c39ede48 (patch)
tree2fe9ee45196c6fa8ee907503dc2bb1495489087c /recipes-connectivity
parent8885505217f4180eb82ffc3ac8b0b9a24f5036b5 (diff)
2nd part of the layer/profile rework [2/2]
Main goal of this is to move the agl-service-* bindings into the core and to unify common recipes like wayland/weston into meta-agl-profile-graphical. As a placeholder for recipes is meta-agl-profile-demo which are being reshuffled. TLDR: remove recipes from meta-agl-demo that were moved to other layers Bug-AGL: SPEC-145 , SPEC-876 , SPEC-877 v2: moving updated udisks changes to meta-agl Change-Id: I873107f00adadeb6f3f266cce37b513fe6d44cf2 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/.gitkeep0
-rw-r--r--recipes-connectivity/bluez5/bluez5/0001_fix_compile_issue_when_using_in_c++.patch23
-rw-r--r--recipes-connectivity/bluez5/bluez5_%.bbappend7
-rw-r--r--recipes-connectivity/libnfc/libnfc_git.bb18
4 files changed, 0 insertions, 48 deletions
diff --git a/recipes-connectivity/.gitkeep b/recipes-connectivity/.gitkeep
deleted file mode 100644
index e69de29b..00000000
--- a/recipes-connectivity/.gitkeep
+++ /dev/null
diff --git a/recipes-connectivity/bluez5/bluez5/0001_fix_compile_issue_when_using_in_c++.patch b/recipes-connectivity/bluez5/bluez5/0001_fix_compile_issue_when_using_in_c++.patch
deleted file mode 100644
index ba2f33c6..00000000
--- a/recipes-connectivity/bluez5/bluez5/0001_fix_compile_issue_when_using_in_c++.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -urN bluez-5.22.orig/lib/bluetooth.h bluez-5.22/lib/bluetooth.h
---- bluez-5.22.orig/lib/bluetooth.h 2013-12-10 15:59:06.000000000 +0900
-+++ bluez-5.22/lib/bluetooth.h 2015-10-28 13:34:25.749335768 +0900
-@@ -158,16 +158,16 @@
- #define bt_get_unaligned(ptr) \
- ({ \
- struct __attribute__((packed)) { \
-- typeof(*(ptr)) __v; \
-- } *__p = (typeof(__p)) (ptr); \
-+ __typeof__(*(ptr)) __v; \
-+ } *__p = (__typeof__(__p)) (ptr); \
- __p->__v; \
- })
-
- #define bt_put_unaligned(val, ptr) \
- do { \
- struct __attribute__((packed)) { \
-- typeof(*(ptr)) __v; \
-- } *__p = (typeof(__p)) (ptr); \
-+ __typeof__(*(ptr)) __v; \
-+ } *__p = (__typeof__(__p)) (ptr); \
- __p->__v = (val); \
- } while(0)
diff --git a/recipes-connectivity/bluez5/bluez5_%.bbappend b/recipes-connectivity/bluez5/bluez5_%.bbappend
deleted file mode 100644
index 59787fce..00000000
--- a/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-APPLY_v522 = "${@str('no' if '${PV}' != '5.22' else 'yes')}"
-
-SRC_URI_append = "\
- file://0001_fix_compile_issue_when_using_in_c++.patch;apply=${APPLY_v522} \
-"
diff --git a/recipes-connectivity/libnfc/libnfc_git.bb b/recipes-connectivity/libnfc/libnfc_git.bb
deleted file mode 100644
index bd216f81..00000000
--- a/recipes-connectivity/libnfc/libnfc_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "libnfc"
-DESCRIPTION = "Platform independent Near Field Communication (NFC) library"
-HOMEPAGE = "https://github.com/nfc-tools/libnfc"
-SECTION = "apps"
-
-DEPENDS = "libusb"
-
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
-
-inherit cmake pkgconfig
-
-SRC_URI = "git://github.com/nfc-tools/libnfc;protocol=https;branch=master"
-SRCREV = "2d4543673e9b76c02679ca8b89259659f1afd932"
-
-PV = "1.7.1+git${SRCPV}"
-S = "${WORKDIR}/git"
-