summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-18 16:22:10 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-18 16:22:10 -0500
commit4091efd9ed80566bf9e3cbba6a414431462a4c27 (patch)
treeb05c50d81785dc3ea75341341abe0e3ad2dba4e3 /recipes-connectivity
parent16cac4f041601038a32ae39d94e8bd835f2fff7e (diff)
Disable btwilink by default on m3ulcb
Testing for CES has found the wilink BT on the M3+Kingfisher somewhat unreliable. To disable it by default for now, add a demo platform configuration hook to packagegroup-agl-demo-platform and use it to pick up a modprobe configuration file to prevent btwilink from loading. This addition is specific to the m3ulcb platform, and the variable DEMO_ENABLE_BTWILINK can be used to over-ride the behavior by setting it to "true" in local.conf or site.conf. Change-Id: Ia645d9329594547f83601526e3f3fd5da5845b24 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/btwilink-disable-conf/btwilink-disable-conf_1.0.bb14
-rw-r--r--recipes-connectivity/btwilink-disable-conf/files/btwilink-disable.conf1
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-connectivity/btwilink-disable-conf/btwilink-disable-conf_1.0.bb b/recipes-connectivity/btwilink-disable-conf/btwilink-disable-conf_1.0.bb
new file mode 100644
index 00000000..9170a84e
--- /dev/null
+++ b/recipes-connectivity/btwilink-disable-conf/btwilink-disable-conf_1.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "btwilink module disabling modprobe configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://btwilink-disable.conf"
+
+COMPATIBLE_MACHINE = "m3ulcb"
+
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 ${WORKDIR}/btwilink-disable.conf ${D}${sysconfdir}/modprobe.d
+}
diff --git a/recipes-connectivity/btwilink-disable-conf/files/btwilink-disable.conf b/recipes-connectivity/btwilink-disable-conf/files/btwilink-disable.conf
new file mode 100644
index 00000000..8d28f629
--- /dev/null
+++ b/recipes-connectivity/btwilink-disable-conf/files/btwilink-disable.conf
@@ -0,0 +1 @@
+install btwilink /bin/false