summaryrefslogtreecommitdiffstats
path: root/recipes-core/nss
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-23 10:22:43 -0400
commit4ed1a0a0302cec13f12d3999466d62841c104402 (patch)
tree3800d3c40398a5441122e5b04bd6aeac6ee88945 /recipes-core/nss
parentfe2024e444f214ed6fd04c37d09c51f1c6a9e8e6 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-core/nss')
-rw-r--r--recipes-core/nss/nss-agl-driver-db_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-core/nss/nss-agl-driver-db_git.bb b/recipes-core/nss/nss-agl-driver-db_git.bb
index b2fb4034..84cb34ed 100644
--- a/recipes-core/nss/nss-agl-driver-db_git.bb
+++ b/recipes-core/nss/nss-agl-driver-db_git.bb
@@ -11,6 +11,9 @@ SRC_URI = "file://${BPN}.service \
file://${BPN}.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -22,8 +25,8 @@ do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -d ${D}${sbindir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}
+ install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}
fi
}