summaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:59:47 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:32:43 -0400
commit0502646dd3538d4f3c9d85f07a8d211c3b48f7fc (patch)
tree053d2f3a69fb80aa8d1f5d686f9dea6431bd7988 /recipes-core/udev/demo-i2c-udev-conf_1.0.bb
parent70dc83d80169ff6398279aed074f94fc060ff361 (diff)
demo-i2c-udev-conf: update for reworked agl-service-hvac
Update demo-i2c-udev-conf recipe and the script and systemd unit it installs to generate the configuration that the reworked agl-service-hvac daemon expects for LED configuration for the demo platform. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I8a746681a5f0acab9aa834796abd3607570e54b4
Diffstat (limited to 'recipes-core/udev/demo-i2c-udev-conf_1.0.bb')
-rw-r--r--recipes-core/udev/demo-i2c-udev-conf_1.0.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
index 332c698b..7707df60 100644
--- a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
+++ b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
@@ -2,27 +2,27 @@ SUMMARY = "USB attached I2C demo hardware udev configuration"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-SRC_URI = "file://hvac-json-in-rewrite.sh \
+SRC_URI = "file://hvac-conf-in-rewrite.sh \
file://rtc-i2c-attach.sh \
- file://hvac-json-in-rewrite@.service \
+ file://hvac-conf-in-rewrite@.service \
file://rtc-i2c-attach@.service \
file://99-agl-led-rtc.rules \
- file://hvac.json.in \
+ file://agl-service-hvac-leds.conf.in \
"
do_compile[noexec] = "1"
do_install() {
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/hvac.json.in ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hvac-json-in-rewrite.sh ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
install -m 0755 ${WORKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/hvac-json-in-rewrite@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
install -d ${D}${sysconfdir}/udev/rules.d