summaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:59:47 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-17 16:44:34 -0400
commit5fdeddef62f6873e0cc726c73760fe9fb8d57b36 (patch)
treea55646d2de921a2a257e755bb642e19541597ee7 /recipes-core/udev/demo-i2c-udev-conf_1.0.bb
parentde875a8bcbad58763d17c1b462970dca10280b95 (diff)
demo-i2c-udev-conf: update for reworked agl-service-hvac
Update demo-i2c-udev-conf recipe and the script and systemd unit it installs to generate the configuration that the reworked agl-service-hvac daemon expects for LED configuration for the demo platform. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Id9ae8413971b5b2189c9fb14ed7cd7cb72f67ab9
Diffstat (limited to 'recipes-core/udev/demo-i2c-udev-conf_1.0.bb')
-rw-r--r--recipes-core/udev/demo-i2c-udev-conf_1.0.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
index 332c698b3..7707df60a 100644
--- a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
+++ b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
@@ -2,27 +2,27 @@ SUMMARY = "USB attached I2C demo hardware udev configuration"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-SRC_URI = "file://hvac-json-in-rewrite.sh \
+SRC_URI = "file://hvac-conf-in-rewrite.sh \
file://rtc-i2c-attach.sh \
- file://hvac-json-in-rewrite@.service \
+ file://hvac-conf-in-rewrite@.service \
file://rtc-i2c-attach@.service \
file://99-agl-led-rtc.rules \
- file://hvac.json.in \
+ file://agl-service-hvac-leds.conf.in \
"
do_compile[noexec] = "1"
do_install() {
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/hvac.json.in ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hvac-json-in-rewrite.sh ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
install -m 0755 ${WORKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/hvac-json-in-rewrite@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
install -d ${D}${sysconfdir}/udev/rules.d