summaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/demo-most-udev-conf_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-14 02:40:33 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-14 02:43:47 +0100
commitd412114c0cf132a77f3b3482c5440b1a1c961b77 (patch)
treec1bf535331d0332dea4171d38f2b026efab99000 /recipes-core/udev/demo-most-udev-conf_1.0.bb
parent2bedc9120bc9cd4a9b06fddffa33216870d9a8f9 (diff)
Add udev rules and scripts for demo platform configurationicefish_8.99.3icefish/8.99.38.99.3
Add recipes for udev rules and associated scripts 1) Support USB attached I2C devices for RTC and HVAC LED support. The RTC support loads and configures the required rtc-ds1307 driver, and sets the time from the RTC clock. The HVAC LED support configures the LED device names for use by the HVAC binding. The new demo-i2c-udev-conf recipe is added to DEMO_PLATFORM_CONF variable in packagegroup-agl-demo-platform to have them added to the agl-demo-platform image. Since they use udev rules to detect the corresponding hardware, this should be safe for all platforms. Change-Id: Id08571b43c7ae9275496980e0a5568e145a1f653 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-core/udev/demo-most-udev-conf_1.0.bb')
-rw-r--r--recipes-core/udev/demo-most-udev-conf_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/udev/demo-most-udev-conf_1.0.bb b/recipes-core/udev/demo-most-udev-conf_1.0.bb
new file mode 100644
index 00000000..ab71f96b
--- /dev/null
+++ b/recipes-core/udev/demo-most-udev-conf_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "MOST demo hardware udev configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://99-agl-fibredyne-amp.rules \
+ file://enable-agl-demo-hal.sh \
+"
+
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/enable-agl-demo-hal.sh ${D}${sbindir}
+
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/99-agl-fibredyne-amp.rules ${D}${sysconfdir}/udev/rules.d/
+}
+
+RDEPENDS_${PN} += "bash"