summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-12-27 14:37:50 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-12-27 16:01:58 +0100
commitcda9d972b6bab2d942468f13edf25118b183b366 (patch)
tree470f5f556d2dad3a0aedd844e26d185ccf89b135 /recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
parent58e35ecf32af3aaf18af1e9576de74892f61cae5 (diff)
Unify locations of applications and demo
This changeset cleans-up the locations used for apps and the ces2017-demo. - Apps go into /usr/AGL/apps - Scripts are available in /usr/AGL/ces2017-demo (symlink) As the ces2017-demo package will go away, its folder will also become obsolete or only host startup-scripts. Change-Id: I2b2ea8dc6de531f737305a80573ad56cb08ba009 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo-hmi/CES2017-demo/CES2017-demo.bb')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index ef4b48d7..20695bad 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -91,6 +91,7 @@ do_install_prepend() {
cat > ${B}/apps/installAllApps.sh <<-EOF
#!/bin/sh
+ cd /usr/AGL/apps
/usr/bin/afm-util install controls.wgt
/usr/bin/afm-util install dashboard.wgt
/usr/bin/afm-util install phone.wgt
@@ -107,12 +108,14 @@ do_install_prepend() {
do_install() {
install -d ${D}/usr/AGL/${PN}
- install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/${PN}/
+ install -d ${D}/usr/AGL/apps
+ install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/apps/
+ install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/apps/
+ install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
+ install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
- install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/${PN}/
+ install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
+ ln -sf ../apps/installAllApps.sh ${D}/usr/AGL/${PN}/installAllApps.sh
install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
@@ -143,6 +146,8 @@ do_install() {
#}
FILES_${PN} += "/usr/AGL/ \
+ /usr/AGL/apps/* \
+ /usr/AGL/${PN}/* \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
/usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \