summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/CES2017-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
committerScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
commit9d13096870330ac11d915893c113d9e25989153c (patch)
treef668477f19cb9b0cef3d81d9f0cb249ef5a81a9e /recipes-demo-hmi/CES2017-demo
parent5f52a2cf2a739ab14c74d54f383e527a2c3676b9 (diff)
Switch to split out demo apps
Add recipes for the split out controls, dashboard, phone, and radio app repositories, remove the related packaging of same from the CES2017-demo recipe, and add the split out apps to IMAGE_AGL_APPS in the agl-demo-platform image definition. Bug-AGL: SPEC-400, SPEC-401, SPEC-402, SPEC-403, SPEC-404 Change-Id: I790eee4edf97ab9c32ddfe5fe277cb7f05012ffc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/CES2017-demo')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb128
-rw-r--r--recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf12
-rw-r--r--recipes-demo-hmi/CES2017-demo/files/presets-CES.conf14
-rw-r--r--recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf14
4 files changed, 19 insertions, 149 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 7d64f83ec..7f902ba80 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -1,116 +1,27 @@
SUMMARY = "App Launcher for the AGL Demonstrator @ CES2017"
DESCRIPTION = "App Lanucher app in QML format for the AGL Demonstrator @ CESS2017"
HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
-LICENSE = "MPL-2.0"
SECTION = "apps"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git/"
-PN = "ces2017-demo"
-
-inherit qmake5
-DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
-
-inherit aglwgt
-
+LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
-# ALS, CES, FOSDEM available
-AGL_RADIO_PRESETS_LOCALE ?= "CES"
+DEPENDS = "homescreen zip-native qtquickcontrols2"
+
+PV = "1.0+git${SRCPV}"
+PN = "ces2017-demo"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
- "
-SRCREV = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
+SRCREV = "${AUTOREV}"
# Pinned branch/SRCREV for Charming Chinook
-SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
- "
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook"
SRCREV_chinook = "354195c83841240ddd5f2c5daad97d66cc9e1d28"
-RDEPENDS_${PN} += " \
- qtmultimedia-qmlplugins \
- qtmultimedia-rtlfm-radio-plugin \
- qtquickcontrols-qmlplugins \
- qtquickcontrols2-qmlplugins \
- qtsvg-plugins \
- "
-
-do_install_prepend() {
- mkdir -p ${B}/package
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"controls\" version=\"0.1\"> \
- <name>Controls</name> \
- <content src=\"controls\" type=\"application/x-executable\"/> \
- <description>Controls app.</description> \
- <author>Qt</author> \
- <icon src=\"controls.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Controls/config.xml
-
- cd ${B}/apps/Controls/
- zip ${B}/package/controls.wgt config.xml controls
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"dashboard\" version=\"0.1\"> \
- <name>Dashboard</name> \
- <content src=\"dashboard\" type=\"application/x-executable\"/> \
- <description>Dashboard app.</description> \
- <author>Qt</author> \
- <icon src=\"dashboard.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Dashboard/config.xml
-
- cd ${B}/apps/Dashboard/
- zip ${B}/package/dashboard.wgt config.xml dashboard
+S = "${WORKDIR}/git/"
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"phone\" version=\"0.1\"> \
- <name>Phone</name> \
- <content src=\"phone\" type=\"application/x-executable\"/> \
- <description>Phone app.</description> \
- <author>Qt</author> \
- <icon src=\"phone.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Phone/config.xml
-
- cd ${B}/apps/Phone/
- zip ${B}/package/phone.wgt config.xml phone
-
-
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"radio\" version=\"0.1\"> \
- <name>Radio</name> \
- <content src=\"radio\" type=\"application/x-executable\"/> \
- <description>Radio app.</description> \
- <author>Qt</author> \
- <icon src=\"radio.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Radio/config.xml
-
- cd ${B}/apps/Radio/
- zip ${B}/package/radio.wgt config.xml radio
-
-}
+inherit qmake5
do_install() {
- install -d ${D}/home/root/app-data/radio
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
-
install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/ImageButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
@@ -133,15 +44,8 @@ do_install() {
install -m 0644 ${S}/imports/qtquickcontrols2aglstyle/images/* ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL/images/
}
-# plain copy in own folder for now
-#do_install() {
-# mkdir -p ${D}/usr/AGL/CES2017/
-# cp -rf ./* ${D}/usr/AGL/CES2017/
-#}
-
-FILES_${PN} += "/usr/AGL/ \
- /home/root/app-data/radio/presets-*.conf \
- /home/root/app-data/radio/presets.conf \
+FILES_${PN} += " \
+ /usr/AGL/ \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
/usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \
@@ -156,4 +60,10 @@ FILES_${PN} += "/usr/AGL/ \
/usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Arrow.svg \
/usr/lib/qt5/qml/QtQuick/Controls.2/AGL \
/usr/lib/qt5/qml/QtQuick/Controls.2/AGL/images \
- "
+"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf b/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf
deleted file mode 100644
index ff5592272..000000000
--- a/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-[fmPresets]
-1\frequency=76100000
-1\title=Inter FM
-2\frequency=77100000
-2\title=The Open University of Japan
-3\frequency=80000000
-3\title=TOKYO FM
-4\frequency=81300000
-4\title=J-WAVE
-5\frequency=82500000
-5\title=NHK FM Tokyo
-size=5
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf b/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf
deleted file mode 100644
index 83caeffe1..000000000
--- a/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-[fmPresets]
-1\frequency=93100000
-1\title=93.1 The Mountain
-2\frequency=94100000
-2\title=Mix 94.1
-3\frequency=96300000
-3\title=96.3 KKLZ
-4\frequency=102700000
-4\title=102.7 THE COYOTE
-5\frequency=88900000
-5\title=News 88.9
-6\frequency=91500000
-6\title=KUNV
-size=6
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf b/recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf
deleted file mode 100644
index b88364f72..000000000
--- a/recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-[fmPresets]
-1\frequency=92100000
-1\title=92.1 Radio Campus
-2\frequency=92500000
-2\title=92.5 RTBF La Première
-3\frequency=93200000
-3\title=93.2 RTBF Classic 21
-4\frequency=98800000
-4\title=98.8 FM Brussel
-5\frequency=103700000
-5\title=103.7 NRJ
-6\frequency=104000000
-6\title=104.0 Bel RTL
-size=6