aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/CES2017-demo
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-11-01 15:15:39 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-01 14:52:08 +0000
commit7de25f68bba5465f547751ad617360c243dd0aff (patch)
treea7d6668a734f1cd473b5f0218929303f18198451 /recipes-demo-hmi/CES2017-demo
parentf0dcd3584751dd52d56c6bfa5d0ae70fcd53982a (diff)
Add CES2017-demo and change image definition
Change-Id: Ia9f4f619bc0c6576e35cd6fc66267938869dd92c Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo-hmi/CES2017-demo')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
new file mode 100644
index 00000000..c94950bf
--- /dev/null
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Homescreen for the AGL Demonstrator @ CES2017"
+DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CESS2017"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
+
+SECTION = "apps"
+
+PN = "ces2017-demo"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0+git"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols-qmlplugins \
+ qtsvg-plugins \
+ "
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ls
+}
+
+# plain copy in own folder for now
+do_install() {
+ mkdir -p ${D}/usr/AGL/CES2017/
+ cp -rf ./* ${D}/usr/AGL/CES2017/
+}
+
+FILES_${PN} = "/usr/AGL/"